Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index 475c830..eb16aca 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -1,3 +1,5 @@
+PACKAGECONFIG:openbmc-phosphor:class-target = ""
+
 #This is largely to improve our build times by not building or installing
 #modules that OpenBMC does not use by our coding standard.  Another thing to
 #note is that for most targets, coroutine and context libraries are also added
@@ -9,5 +11,3 @@
 #https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
 #
 BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
-PACKAGECONFIG:openbmc-phosphor:class-target = ""
-