meta-nicole: Add image signature verification

Adds a firmware image signature verification.

This brings:
 - The key is stored in `/etc/activationdata` folder.
 - The software item activation now begins with signature verification.
   The verification failure stops the activation only when the
   `fieldMode` is set to true.
   See https://github.com/openbmc/phosphor-dbus-interfaces/blob/master/xyz/openbmc_project/Control/FieldMode.interface.yaml

(From meta-yadro rev: f9e0ad9f1bb2a2520651f771e2b873bef384423a)

Change-Id: I91cf92d15d29737a9cd05120b194189eb767636e
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/flash/openpower-software-manager_%.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/flash/openpower-software-manager_%.bbappend
new file mode 100644
index 0000000..a2df9cf
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/flash/openpower-software-manager_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG_append = " verify_pnor_signature"