meta-openembedded: subtree update:ce51958eca..a2928764c2
Adrian Bunk (3):
python3-cmd2: Remove PNBLACKLIST
php: Remove no longer needed CFLAGS_append_aarch64
php: Move more into php.inc after php5 removal
Alistair Francis (4):
python3-requests-future: Initial commit of 0.9.5
python3-xmlrunner: Initial commit of 1.7.7
python3-fasteners: Initial commit of 0.15
python3-python-vlc: Initial commit of 3.0.7110
Anuj Mittal (3):
python3-defusedxml: add recipe
python-networkx: upgrade 2.1 -> 2.2
python3-networkx: add recipe
Khem Raj (9):
php: Turn PCRE JIT off for riscv
redis: Fix build with clang/x86
android-tools: Recognise i686 for HOST_ARCH
netdata: Update to 1.17.0 and fix build with clang/x86
safec: Define _GNU_SOURCE
safec: Upgrade to 3.5 release
openocd: Add --disable-werror always
breakpad: Update dont-clobber-rsp patch to latest
gparted: add to deps instead of overwriting
Martin Jansa (3):
remmina: add distro_features_check for GTK3DISTROFEATURES
ceres-solver: fix the paths in .cmake files
ceres-solver: add PACKAGECONFIG for suitesparse and lapack
Naveen Saini (1):
pm-graph: upgrade 5.3 -> 5.5
Oleksandr Kravchuk (1):
analyze-suspend: update to 5.5
Peter Kjellerstedt (1):
lvm2/libdevmapper: Make it build for native
Randy MacLeod (1):
poppler: update from 0.79.0 to 0.80.0
Slater, Joseph (1):
openhpi: control snmp-bc ptest generation
Stefan Agner (1):
fuse3: add libfuse3 recipe
Trevor Gamblin (1):
gvfs: upgrade 1.40.2 -> 1.41.2 for CVE fixes
Yi Zhao (2):
php: fix module path in mod_php.conf
apache-websocket: fix module path
Yuan Chao (2):
python-atomicwrites: new recipe
python-pytest: fix runtime error
Zang Ruochen (1):
python-certifi: upgrade 2019.6.16 -> 2019.9.11
Change-Id: Iba065b25686a1ac22d647226d9ea0c61c5b4578f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.80.0.bb b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.80.0.bb
new file mode 100644
index 0000000..338af1d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.80.0.bb
@@ -0,0 +1,50 @@
+SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
+ file://0001-Do-not-overwrite-all-our-build-flags.patch \
+ file://basename-include.patch \
+ "
+SRC_URI[md5sum] = "8ff9964d1fcc9c334a9c66f6f426ab9c"
+SRC_URI[sha256sum] = "4d3ca6b79bc13b8e24092e34f83ef5f387f3bb0bbd7359a6c078e09c696d104f"
+
+DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
+
+inherit cmake pkgconfig gobject-introspection
+
+PACKAGECONFIG ??= "jpeg openjpeg png tiff nss ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
+PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
+PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
+PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff"
+PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
+PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
+PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
+PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
+
+# surprise - did not expect this to work :)
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
+
+SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
+
+EXTRA_OECMAKE += " \
+ -DENABLE_CMS=lcms2 \
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
+ -DBUILD_GTK_TESTS=OFF \
+ -DENABLE_ZLIB=ON \
+ -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
+ ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
+"
+
+do_configure_append() {
+ # poppler macro uses pkg-config to check for g-ir runtimes. Something
+ # makes them point to /usr/bin. Align them to sysroot - that's where the
+ # gir-wrappers are:
+ sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja
+}
+
+PACKAGES =+ "libpoppler libpoppler-glib"
+FILES_libpoppler = "${libdir}/libpoppler.so.*"
+FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
+
+RDEPENDS_libpoppler = "poppler-data"