meta-openembedded: subtree update:ce51958eca..a2928764c2
Adrian Bunk (3):
python3-cmd2: Remove PNBLACKLIST
php: Remove no longer needed CFLAGS_append_aarch64
php: Move more into php.inc after php5 removal
Alistair Francis (4):
python3-requests-future: Initial commit of 0.9.5
python3-xmlrunner: Initial commit of 1.7.7
python3-fasteners: Initial commit of 0.15
python3-python-vlc: Initial commit of 3.0.7110
Anuj Mittal (3):
python3-defusedxml: add recipe
python-networkx: upgrade 2.1 -> 2.2
python3-networkx: add recipe
Khem Raj (9):
php: Turn PCRE JIT off for riscv
redis: Fix build with clang/x86
android-tools: Recognise i686 for HOST_ARCH
netdata: Update to 1.17.0 and fix build with clang/x86
safec: Define _GNU_SOURCE
safec: Upgrade to 3.5 release
openocd: Add --disable-werror always
breakpad: Update dont-clobber-rsp patch to latest
gparted: add to deps instead of overwriting
Martin Jansa (3):
remmina: add distro_features_check for GTK3DISTROFEATURES
ceres-solver: fix the paths in .cmake files
ceres-solver: add PACKAGECONFIG for suitesparse and lapack
Naveen Saini (1):
pm-graph: upgrade 5.3 -> 5.5
Oleksandr Kravchuk (1):
analyze-suspend: update to 5.5
Peter Kjellerstedt (1):
lvm2/libdevmapper: Make it build for native
Randy MacLeod (1):
poppler: update from 0.79.0 to 0.80.0
Slater, Joseph (1):
openhpi: control snmp-bc ptest generation
Stefan Agner (1):
fuse3: add libfuse3 recipe
Trevor Gamblin (1):
gvfs: upgrade 1.40.2 -> 1.41.2 for CVE fixes
Yi Zhao (2):
php: fix module path in mod_php.conf
apache-websocket: fix module path
Yuan Chao (2):
python-atomicwrites: new recipe
python-pytest: fix runtime error
Zang Ruochen (1):
python-certifi: upgrade 2019.6.16 -> 2019.9.11
Change-Id: Iba065b25686a1ac22d647226d9ea0c61c5b4578f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb
new file mode 100644
index 0000000..b94929d
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Small add-on for the python requests http library. Makes use of python 3.2’s concurrent.futures or the backport for prior versions of python."
+HOMEPAGE = "https://github.com/ross/requests-futures"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e1e50798d0afe0e1f87594c6619a2fa5"
+
+SRC_URI[md5sum] = "e20dc6f063c70888a7f8225e349b6682"
+SRC_URI[sha256sum] = "33aa8a3b7892850701707d7e094b1e1ce7c4f7a36ff2a1dcc2da4e01a1a00f7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ python3-requests \
+"
+