meta-raspberrypi: subtree update:8cffbf5e85..ffc402ef5e

Andrei Gherzan (1):
      layer.conf: Define LAYERDEPENDS

Changqing Li (1):
      99-com.rules: fix error invalid substitution type

Khem Raj (2):
      linux-firmware-rpidistro: Update to 20190114-1+rpt11
      bluez-firmware-rpidistro: Update to 1.2-4+rpt8

Martin Jansa (3):
      linux-raspberrypi: allow to change the yocto-kernel-cache branch with LINUX_RPI_KMETA_BRANCH
      linux-raspberrypi-dev: drop protocol=git and add LINUX_RPI_KMETA_BRANCH
      linux-raspberrypi-dev: use static SRCREV when not selected with PREFERRED_PROVIDER_virtual/kernel

Pierre-Jean Texier (1):
      rpi-base: make SPLASH overridable from outside

SCVready (1):
      rpi-config: comment updated

matt-hammond-bbc (1):
      libva: Fix for when using `userland`

sss22213 (1):
      recipes-bsp: Add support for Raspberry Pi HD quality camera

Change-Id: I631fa1d4c12b9f91d5044712b6c2e712fcebd98b
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-raspberrypi/recipes-kernel/bluez-firmware-rpidistro/bluez-firmware-rpidistro_git.bb b/meta-raspberrypi/recipes-kernel/bluez-firmware-rpidistro/bluez-firmware-rpidistro_git.bb
index 310d2f8..d28e2c1 100644
--- a/meta-raspberrypi/recipes-kernel/bluez-firmware-rpidistro/bluez-firmware-rpidistro_git.bb
+++ b/meta-raspberrypi/recipes-kernel/bluez-firmware-rpidistro/bluez-firmware-rpidistro_git.bb
@@ -16,7 +16,7 @@
 # [^1]: https://github.com/RPi-Distro/bluez-firmware/issues/1
 LICENSE = "Firmware-cypress-rpidistro"
 LIC_FILES_CHKSUM = "\
-    file://LICENCE.cypress-rpidistro;md5=852f9d10cbedba1f6c439729bd0617b4 \
+    file://LICENCE.cypress-rpidistro;md5=c5d12ae0b24ef7177902a8e288751a4e \
 "
 
 # These are not common licenses, set NO_GENERIC_LICENSE for them
@@ -24,8 +24,8 @@
 NO_GENERIC_LICENSE[Firmware-cypress-rpidistro] = "LICENCE.cypress-rpidistro"
 
 SRC_URI = "git://github.com/RPi-Distro/bluez-firmware"
-SRCREV = "96eefffcccc725425fd83be5e0704a5c32b79e54"
-PV = "0.0+git${SRCPV}"
+SRCREV = "e7fd166981ab4bb9a36c2d1500205a078a35714d"
+PV = "1.2-4+rpt8"
 
 S = "${WORKDIR}/git"
 
@@ -55,11 +55,15 @@
 PACKAGES = "\
     ${PN}-cypress-license \
     ${PN}-bcm43430a1-hcd \
+    ${PN}-bcm43430b0-hcd \
     ${PN}-bcm4345c0-hcd \
+    ${PN}-bcm4345c5-hcd \
 "
 
 LICENSE_${PN}-bcm43430a1-hcd = "Firmware-cypress-rpidistro"
+LICENSE_${PN}-bcm43430b0-hcd = "Firmware-cypress-rpidistro"
 LICENSE_${PN}-bcm4345c0-hcd = "Firmware-cypress-rpidistro"
+LICENSE_${PN}-bcm4345c5-hcd = "Firmware-cypress-rpidistro"
 LICENSE_${PN}-cypress-license = "Firmware-cypress-rpidistro"
 
 FILES_${PN}-cypress-license = "\
@@ -68,16 +72,28 @@
 FILES_${PN}-bcm43430a1-hcd = "\
     ${nonarch_base_libdir}/firmware/brcm/BCM43430A1.hcd \
 "
+FILES_${PN}-bcm43430b0-hcd = "\
+    ${nonarch_base_libdir}/firmware/brcm/BCM43430B0.hcd \
+"
 FILES_${PN}-bcm4345c0-hcd = "\
     ${nonarch_base_libdir}/firmware/brcm/BCM4345C0.hcd \
 "
+FILES_${PN}-bcm4345c5-hcd = "\
+    ${nonarch_base_libdir}/firmware/brcm/BCM4345C5.hcd \
+"
 
 RDEPENDS_${PN}-bcm43430a1-hcd += "${PN}-cypress-license"
+RDEPENDS_${PN}-bcm43430b0-hcd += "${PN}-cypress-license"
 RDEPENDS_${PN}-bcm4345c0-hcd += "${PN}-cypress-license"
+RDEPENDS_${PN}-bcm4345c5-hcd += "${PN}-cypress-license"
 RCONFLICTS_${PN}-bcm43430a1-hcd = "linux-firmware-bcm43430a1-hcd"
 RREPLACES_${PN}-bcm43430a1-hcd = "linux-firmware-bcm43430a1-hcd"
+RCONFLICTS_${PN}-bcm43430b0-hcd = "linux-firmware-bcm43430b0-hcd"
+RREPLACES_${PN}-bcm43430b0-hcd = "linux-firmware-bcm43430b0-hcd"
 RCONFLICTS_${PN}-bcm43435c0-hcd = "linux-firmware-bcm4345c0-hcd"
 RREPLACES_${PN}-bcm43435c0-hcd = "linux-firmware-bcm4345c0-hcd"
+RCONFLICTS_${PN}-bcm43435c5-hcd = "linux-firmware-bcm4345c5-hcd"
+RREPLACES_${PN}-bcm43435c5-hcd = "linux-firmware-bcm4345c5-hcd"
 
 # Firmware files are generally not run on the CPU, so they can be
 # allarch despite being architecture specific