Use openpower-proc-control in bitbake
The executable built from this repository will now be
used in start_host@.service and vcs_workaround@.service
instead of the shell scripts that use pdbg to do FSI commands.
Change-Id: I8ef3075449b562d64295ae330bd2c150264a0607
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
index 16d24c7..0caa074 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
@@ -5,22 +5,14 @@
inherit obmc-phosphor-systemd
inherit obmc-phosphor-license
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-pdbg-host-control:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "pdbg \
- p9-vcs-workaround"
+RDEPENDS_${PN} += "p9-vcs-workaround op-proc-control"
S = "${WORKDIR}"
-SRC_URI += "file://start_host.sh"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/start_host.sh \
- ${D}${bindir}/start_host.sh
-}
TMPL = "start_host@.service"
INSTFMT = "start_host@{0}.service"
@@ -29,4 +21,3 @@
SYSTEMD_SERVICE_${PN} += "${TMPL}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}"