meta-openpower: phal devtree data import service
Service to override r/w devtree attribute data to the
newer version of devtree from older version. This is used
in concurrent software update followed BMC reboot.
This service will only run in the following condition:
- Chassis power is on when the BMC comes out of reset
- version bump to enable service back-end support
Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Change-Id: I352c60ba254cfcf50a2339224eab9fa418491cc7
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index c0132b8..a30a3e4 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -61,7 +61,12 @@
LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
TARGET="../op-reset-host-check@.service"
ln -s $TARGET $LINK
- fi
+
+ mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ TARGET="../phal-import-devtree@.service"
+ ln -s $TARGET $LINK
+ fi
# If the memory preserving reboot feature is enabled, set it up
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
@@ -111,6 +116,9 @@
LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled