quanta: update gsj machine configuration
Commit GSJ project configurations.
1. Add configuration for u-boot-evn.
2. Update kernel configuration.
3. Add gsj suffix to some properties.
Tested: Build Quanta GSJ image and load on the GSJ BMC module.
Ensure that BMC boots to console successfully.
(From meta-quanta rev: fc91a4374e2576e940f9c70f34cfe5af9d0aa727)
Change-Id: I2de3b60db65f744bdc1a573efd063b999aa2536e
Signed-off-by: Fran Hsu <Fran.Hsu@quantatw.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend b/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
new file mode 100644
index 0000000..c5aea40
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
+
+SRC_URI_append_gsj = " file://fw_env.config"
+
+do_install_append_gsj () {
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}