meta-quanta: gbs: failsafe fan speed control dynamically

1. add acpi-power-state daemon to check the ACPI power
   states from BIOS

2. set failsafe fan speed at different states
   - S0_G0_D0: 90%
   - S5_G2: 40%

   Note:
   this item depends on the commit and will
   add as the patches first in another PR
   https://gerrit.openbmc-project.xyz/38112

3. add gbs-check-host-state.sh to monitor the power state
   D-Bus and then trigger to set fan failsafe speed

4. remove gbs-detect-fan-fail service and unused scripts
   from phosphor-pid-control

5. update read-margin-temp srcrev to avoid nvme temperature
   sensor failed due to nvme SSD not-present

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I496dd7bc59076a2b3690e367877d49533855c9fe
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 27c3c9f..9cea5db 100644
--- a/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -13,7 +13,6 @@
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-ecc"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " gbs-sysinit"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " gbs-ipmi-entity-association-map"
-OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " gbs-detect-fan-fail"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " usb-network"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " mac-address"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-image-signing"
@@ -22,3 +21,4 @@
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " gbs-nvme-pwr-ctrl"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " read-margin-temp"
 OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-virtual-sensor"
+OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " acpi-power-state-daemon"