meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef
Callaghan, Dan (1):
lmsensors: add a PACKAGECONFIG for sensord
Changqing Li (1):
ntp: fix package split wrongly when enabled usrmerge
Khem Raj (1):
remove spurious file
Nathan Rossi (3):
libeigen: Add native and nativesdk to BBCLASSEXTEND
python*-pyusb: Add native and nativesdk to BBCLASSEXTEND
python*-pyserial: Add native and nativesdk to BBCLASSEXTEND
Oleksandr Kravchuk (23):
babl: update to 0.1.62
znc: update to 1.7.4
zlog: update to 1.2.14
wipe: update to 0.24
upower: update to 0.99.11
python-pyobject: update to 3.34.0
python-pytoml: update to 0.1.21
python-cpuset: update to 1.6
libwebsockets: update to 3.2.0
libvpx: update to 1.8.1
libvdpau: update to 1.3
libmicrohttpd: update to 0.9.66
lcms: update to 2.9
libblockdev: update to 2.23
libbytesize: update to 2.1
iwd: update to 0.20
gsl: update to 2.6
gflags: update to 2.2.2
digitemp: update to 3.7.2
catch2: update to 2.9.2
botan: update to 2.11.0
agent-proxy: update to 1.97
ceres-solver: fix package version
Paul Eggleton (1):
mosquitto: update to 1.6.5
Scott Ellis (1):
wireguard: Upgrade 20190905 to 20190913
Trevor Gamblin (1):
openjpeg: upgrade 2.3.0 -> 2.3.1
Yi Zhao (1):
samba: upgrade 4.10.7 -> 4.10.8
Zang Ruochen (2):
python-dbus: upgrade 1.2.10 -> 1.2.12
python-pluggy: upgrade 0.12.0 -> 0.13.0
Zheng Ruoqin (1):
xrdp: 0.9.4 -> 0.9.11
Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb b/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb
new file mode 100644
index 0000000..c4cc627
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
+
+DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib"
+
+SRC_URI = " \
+ http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+"
+SRC_URI[md5sum] = "abe6acb617f11f2e8dbd9846fcf86e24"
+SRC_URI[sha256sum] = "64b5ffbfccd5bdb15d925777979a4dbee1a957f9eaeb158dc76175267eddbdef"
+
+inherit autotools pkgconfig gettext gobject-introspection systemd distro_features_check
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
+PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
+ --without-systemdutildir --without-systemdsystemunitdir,systemd"
+
+EXTRA_OECONF = " --with-backend=linux"
+
+SYSTEMD_SERVICE_${PN} = "upower.service"
+# don't start on boot by default - dbus does that on demand
+SYSTEMD_AUTO_ENABLE = "disable"
+
+do_configure_prepend() {
+ sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+RDEPENDS_${PN} += "dbus"
+RRECOMMENDS_${PN} += "pm-utils"
+FILES_${PN} += "${datadir}/dbus-1/ \
+ ${base_libdir}/udev/* \
+"