meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef

Callaghan, Dan (1):
      lmsensors: add a PACKAGECONFIG for sensord

Changqing Li (1):
      ntp: fix package split wrongly when enabled usrmerge

Khem Raj (1):
      remove spurious file

Nathan Rossi (3):
      libeigen: Add native and nativesdk to BBCLASSEXTEND
      python*-pyusb: Add native and nativesdk to BBCLASSEXTEND
      python*-pyserial: Add native and nativesdk to BBCLASSEXTEND

Oleksandr Kravchuk (23):
      babl: update to 0.1.62
      znc: update to 1.7.4
      zlog: update to 1.2.14
      wipe: update to 0.24
      upower: update to 0.99.11
      python-pyobject: update to 3.34.0
      python-pytoml: update to 0.1.21
      python-cpuset: update to 1.6
      libwebsockets: update to 3.2.0
      libvpx: update to 1.8.1
      libvdpau: update to 1.3
      libmicrohttpd: update to 0.9.66
      lcms: update to 2.9
      libblockdev: update to 2.23
      libbytesize: update to 2.1
      iwd: update to 0.20
      gsl: update to 2.6
      gflags: update to 2.2.2
      digitemp: update to 3.7.2
      catch2: update to 2.9.2
      botan: update to 2.11.0
      agent-proxy: update to 1.97
      ceres-solver: fix package version

Paul Eggleton (1):
      mosquitto: update to 1.6.5

Scott Ellis (1):
      wireguard: Upgrade 20190905 to 20190913

Trevor Gamblin (1):
      openjpeg: upgrade 2.3.0 -> 2.3.1

Yi Zhao (1):
      samba: upgrade 4.10.7 -> 4.10.8

Zang Ruochen (2):
      python-dbus: upgrade 1.2.10 -> 1.2.12
      python-pluggy: upgrade 0.12.0 -> 0.13.0

Zheng Ruoqin (1):
      xrdp: 0.9.4 -> 0.9.11

Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb b/meta-openembedded/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb
new file mode 100644
index 0000000..75caf8d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/xrdp/xrdp_0.9.11.bb
@@ -0,0 +1,97 @@
+SUMMARY = "An open source remote desktop protocol(rdp) server."
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=72cfbe4e7bd33a0a1de9630c91195c21 \
+"
+
+inherit distro_features_check autotools pkgconfig useradd systemd
+
+DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native"
+
+REQUIRED_DISTRO_FEATURES = "x11 pam"
+
+SRC_URI = "git://github.com/neutrinolabs/xrdp.git \
+           file://xrdp.sysconfig \
+           file://0001-Added-req_distinguished_name-in-etc-xrdp-openssl.con.patch \
+           file://0001-Fix-the-compile-error.patch \
+           "
+
+SRCREV = "1e4b03eb3c9aa7173de251a328c93c073dcc0fca"
+
+PV = "0.9.11"
+
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[fuse] = " --enable-fuse, --disable-fuse, fuse"
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "--system xrdp"
+USERADD_PARAM_${PN}  = "--system --home /var/run/xrdp -g xrdp \
+                        --no-create-home --shell /bin/false xrdp"
+
+FILES_${PN} += "${datadir}/dbus-1/services/*.service \
+                ${datadir}/dbus-1/accessibility-services/*.service "
+
+FILES_${PN}-dev += "${libdir}/xrdp/libcommon.so \
+                    ${libdir}/xrdp/libxrdp.so \
+                    ${libdir}/xrdp/libscp.so \
+                    ${libdir}/xrdp/libxrdpapi.so "
+
+EXTRA_OECONF = "--enable-pam-config=suse"
+
+do_configure_prepend() {
+    cd ${S}
+    ./bootstrap
+    cd -
+}
+
+do_compile_prepend() {
+    sed -i 's/(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am/(MAKE) $(AM_MAKEFLAGS) install-exec-am/g' ${S}/keygen/Makefile.in
+}
+
+
+do_install_append() {
+	install -d ${D}${sysconfdir} 
+	install -d ${D}${sysconfdir}/xrdp
+	install -d ${D}${sysconfdir}/xrdp/pam.d
+	install -d ${D}${sysconfdir}/sysconfig/xrdp
+   
+	# deal with systemd unit files
+	install -d ${D}${systemd_unitdir}/system
+	install -m 0644 ${S}/instfiles/xrdp.service.in ${D}${systemd_unitdir}/system/xrdp.service
+	install -m 0644 ${S}/instfiles/xrdp-sesman.service.in ${D}${systemd_unitdir}/system/xrdp-sesman.service 
+	sed -i -e 's,@localstatedir@,${localstatedir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service
+	sed -i -e 's,@sysconfdir@,${sysconfdir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service
+	sed -i -e 's,@sbindir@,${sbindir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service
+
+	install -m 0644 ${S}/instfiles/*.ini ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${S}/sesman/sesman.ini.in ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${S}/sesman/startwm.sh ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${S}/xrdp/xrdp.ini.in ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${S}/xrdp/xrdp_keyboard.ini ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${S}/instfiles/xrdp.sh ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${S}/keygen/openssl.conf ${D}${sysconfdir}/xrdp/
+	install -m 0644 ${WORKDIR}/xrdp.sysconfig ${D}${sysconfdir}/sysconfig/xrdp/
+	chown xrdp:xrdp ${D}${sysconfdir}/xrdp
+}
+
+SYSTEMD_SERVICE_${PN} = "xrdp.service xrdp-sesman.service"
+
+pkg_postinst_${PN}() {
+	if test -z "$D"
+	then
+		if test -x ${bindir}/xrdp-keygen
+		then
+			${bindir}/xrdp-keygen xrdp ${sysconfdir}/xrdp/rsakeys.ini >/dev/null
+                fi
+		if test ! -s ${sysconfdir}/xrdp/cert.pem
+		then
+			openssl req -x509 -newkey rsa:2048 -sha256 -nodes -days 3652 \
+			-keyout ${sysconfdir}/xrdp/key.pem \
+			-out ${sysconfdir}/xrdp/cert.pem \
+			-config ${sysconfdir}/xrdp/openssl.conf >/dev/null 2>&1
+			chmod 400 ${sysconfdir}/xrdp/key.pem
+		fi			
+        fi
+}