meta-openembedded: subtree update:1ecd8b4364..f3018013ff
Adrian Bunk (1):
Add irda-utils
Khem Raj (1):
openocd: Upgrade to latest git version
Martin Jansa (8):
gtkwave: add distro_features_check
ndctl: make MACHINE_ARCH and ignore from libblockdev
oprofile: make MACHINE_ARCH
umip: make MACHINE_ARCH
mscgen: fix SRC_URI for multilib
python-cassandra-driver.inc: fix DEPENDS
triggerhappy: fix issues
opencv: use the same package name in PACKAGES and RDEPENDS
Oleksandr Kravchuk (4):
znc: update to 1.7.3
pure-ftpd: update to 1.0.47
xl2tpd: update to 1.3.14
ell: remove recipe
Scott Ellis (1):
wireguard: Upgrade 20190123 -> 20190406
Tom Rini (1):
toybox: Re-order inherit location so we can override do_configure
Zang Ruochen (8):
python-pyparsing: upgrade 2.2.0 -> 2.4.0
python-six: upgrade 1.11.0 -> 1.12.0
python-typing: upgrade 3.6.4 -> 3.6.6
python-urllib3: upgrade 1.23 -> 1.25.2
python-wrapt: upgrade 1.10.11 -> 1.11.1
python-mako:upgrade 1.0.9 -> 1.0.10
python-pip: upgrade 19.1 -> 19.1.1
python-pysocks: upgrade 1.6.8 -> 1.7.0
Change-Id: I9a4d8fb60195b1cfd0f39cebf8b113b3bb63808d
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb
new file mode 100644
index 0000000..f782650
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+HOMEPAGE = "https://pip.pypa.io/"
+LICENSE = "MIT & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
+
+SRC_URI[md5sum] = "4fb98a060f21c731d6743b90a714fc73"
+SRC_URI[sha256sum] = "44d3d7d3d30a1eb65c7e5ff1173cdf8f7467850605ac7cc3707b6064bddd0958"
+
+inherit pypi setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc"
+
+BBCLASSEXTEND = "native nativesdk"