obmc-libobmc-intf: Add Swift gpio definitions

Add gpio definitions for the Swift machine under a swift subdir.
Move the witherspoon gpio definitions under a witherspoon subdir.

Tested: Built swift and witherspoon and checked that the file
        rootfs/etc/default/obmc/gpio/gpio_defs.json was correct
        for each machine.

(From meta-ibm rev: dc61626406fc94962d31742832be83e574a28ee1)

Change-Id: I812d1c0547744967d375984552f03f4702439de3
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
index 72d991c..f245296 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -1 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}/"
+FILESEXTRAPATHS_prepend_witherspoon-128 := "${THISDIR}/${PN}/witherspoon:"