treewide: reduce append operators on SRC_URI

In a base bb file where we are setting the primary git repository, it
is rare that we need to `SRC_URI +=`.  This is an unnecessary pattern
that seems to have been copied throughout the repository.  Remove the
pattern where appropriate and simply set SRC_URI directly.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I430186a82f9582ba6196f5bf66b659af4092b48d
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 59ed688..4369554 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -10,7 +10,7 @@
 inherit meson obmc-phosphor-utils pkgconfig
 inherit systemd
 
-SRC_URI += "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
 SRCREV = "be14ec2d4350ba245538ad0330587af809fa31c2"
 
 DEPENDS += " \