Squashed 'yocto-poky/' content from commit ea562de

git-subtree-dir: yocto-poky
git-subtree-split: ea562de57590c966cd5a75fda8defecd397e6436
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
new file mode 100644
index 0000000..156b329
--- /dev/null
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Common X11 scripts and configuration files"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+SECTION = "x11"
+PR = "r47"
+
+inherit distro_features_check
+# rdepends on xdypinfo xmodmap xinit
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "file://etc \
+           file://gplv2-license.patch"
+
+S = "${WORKDIR}"
+
+do_install() {
+	cp -R ${S}/etc ${D}${sysconfdir}
+	chmod -R 755 ${D}${sysconfdir}
+	find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
+}
+
+RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"
+