meta-aspeed: Correct the offset to load kernel
OpenBMC places kernel at offset 512 if the flash size is 32MB,
but it was defined as 1024 in the present defconfig.
This patch corrects the offset if the flash size is set to 32MB.
Signed-off-by: Howard Chiu <howard_chiu@aspeedtech.com>
Change-Id: I05749eda519cc1660921e111a36be74cb121fa68
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 22976ef..1a7e8f5 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -10,10 +10,13 @@
SRC_URI += "file://fw_env_ast2600_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"
+SRC_URI += "file://fw_env_flash_32M_nor.config"
SRC_URI += "file://fw_env_flash_64M_nor.config"
+SRC_URI:append:uboot-flash-32768 = " file://u-boot_flash_32M.cfg"
ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
+ENV_CONFIG_FILE:uboot-flash-32768 = "fw_env_flash_32M_nor.config"
ENV_CONFIG_FILE:uboot-flash-65536 = "fw_env_flash_64M_nor.config"
INSANE_SKIP:${PN} = "already-stripped"