meta-google: nftables-systemd: Parse rules in a useful order

We want to make sure rules get parsed in a sensible order, following a
sorting order similar to systemd units.

Change-Id: Ica06c953dba793d89d50c6b4cfc8e8a2eb1f58de
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-google/nftables/nftables-systemd.bb b/meta-google/recipes-google/nftables/nftables-systemd.bb
index 03694c8..f4109dd 100644
--- a/meta-google/recipes-google/nftables/nftables-systemd.bb
+++ b/meta-google/recipes-google/nftables/nftables-systemd.bb
@@ -8,7 +8,11 @@
 
 inherit systemd
 
-SRC_URI += "file://nftables.service"
+SRC_URI += " \
+  file://nft-configure.sh \
+  file://nftables.service \
+  "
+
 SYSTEMD_SERVICE_${PN} += "nftables.service"
 
 RDEPENDS_${PN} += " \
@@ -17,6 +21,9 @@
   "
 
 do_install() {
-    install -d ${D}${systemd_system_unitdir}
-    install -m 0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}
+  install -d ${D}${libexecdir}
+  install -m0755 ${WORKDIR}/nft-configure.sh ${D}${libexecdir}/
+
+  install -d ${D}${systemd_system_unitdir}
+  install -m0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}/
 }