meta-aspeed: socsec: Bump to v0.2.1
Andrew Jeffery (10):
resocsec: Style cleanup via autopep8
resocsec: Use env(1) for shebang
resocsec: Consistently use single-quotes for strings
resocsec: Make signing helper options mutually exclusive
resocsec: Add a helper for frobbing the RSA algorithm slug
resocsec: Attempt at ergonomic Chain-of-Trust options
resocsec: Rename secure-bootloader to secure-bootstrap-image
resocsec: Add secure-chained-images subcommand
resocsec: Add verify-secure-image subcommand
setup: Install resocsec
Johnny Huang (43):
Merge branch 'develop' into resocsec
Merge pull request #7 from amboar/resocsec
resocsec: fix typo
socsec: add support for ast2605
socsec: remove hexdump module dependcy
schema: update otp schema
otptool: fix making strap region
otptool: fix schema typo
readme: add descripton of verify
strap: fix "VGA class code" info
otptool: fix schema key
otptool: fix OTPCFG0[14] description for 2600A1
socsec: move hexdump to global
otptool: add 'print' function for otptool
socsec: fix public key exponent
otp_info: fix config typo
otptool: add AST2600A3 support
socsec: add rsa pss padding for AST1030A1
socsec: fix cot public key exponent
socsec: Add new test item
socsec: Add 2600A3 test item
Merge branch 'develop'
socsec: add mode2v2aes2 pub and priv test
socsec: add ecdsa mode for AST1030A1
socsec: Add ecdsa test item
otp_info: remove ast1030 from otp_info
otp_info: update schema
socsec: update revision id
otptool: update schema for manifest id config
socsec: fix revision id range.
socsec: fix f-strings giving SyntaxError
socsec: deprecate the CoT sing function
otptool: fix bitarray AttributeError
readme: update readme and fix typo
otp_info: update otp info
tool: add info2sample tool
otp_info: Add AST2600A3 otp config
otp_info: update and add OTPSTRAP Reserved info
otptool: fix otptool print
otptool: make image also generate OTPCFG1
tool: add script to generate otp config schema
setup: update version number
Merge branch 'develop'
Change-Id: Ie78aa2c0ddb18d823e1055a67c76967aa9762285
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-aspeed/recipes-aspeed/python/socsec_git.bb b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
index 07b966c..6034b29 100644
--- a/meta-aspeed/recipes-aspeed/python/socsec_git.bb
+++ b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
@@ -4,10 +4,10 @@
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d50b901333b4eedfee074ebcd6a6d611"
-SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=develop"
+SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=master"
-PV = "1.7+git${SRCPV}"
-SRCREV = "54cdd3b26262e66d2020a04cba55bc8b02090f1a"
+PV = "0.2.1+git${SRCPV}"
+SRCREV = "51bd4504bffb5044264cfe4c63b8fe8d48a114a9"
S = "${WORKDIR}/git"
@@ -15,7 +15,7 @@
RDEPENDS:${PN} += "python3-bitarray"
RDEPENDS:${PN} += "python3-core"
-RDEPENDS:${PN} += "python3-hexdump"
+RDEPENDS:${PN} += "python3-ecdsa"
RDEPENDS:${PN} += "python3-jsonschema"
RDEPENDS:${PN} += "python3-jstyleson"
RDEPENDS:${PN} += "python3-pycryptodome"