phosphor-power: Only build monitor when told to

The 'monitor' package provides a power supply monitor application that
uses an org.open_power phosphor-dbus-interface that is only used
on a subset of the OpenPower systems.

So that non OpenPower systems can use phosphor-power and not need to
include the org.open_power D-Bus interfaces, add a packageconfig option
for this application to turn off its compilation.  It will then only be
enabled for certain machines.

Fixes openbmc/phosphor-power#6

Tested:
Built Witherspoon, application still built and installed.
Built Rainier, application not built.

Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: Ib7fca16217d93b7d021ba8fb6659e9ddca17d1d9
diff --git a/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend b/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend
index c8084b3..c2f5b2c 100644
--- a/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend
+++ b/meta-ibm/recipes-phosphor/power/phosphor-power_%.bbappend
@@ -11,6 +11,10 @@
 DEPENDS_append_ibm-ac-server = " power-sequencer"
 DEPENDS_append_p10bmc = " power-sequencer"
 
+PACKAGECONFIG_append_ibm-ac-server = " monitor"
+PACKAGECONFIG_append_swift = " monitor"
+PACKAGECONFIG_append_mihawk = " monitor"
+
 do_install_append(){
     install -D ${WORKDIR}/psu.json ${D}${datadir}/phosphor-power/psu.json
 }