telemetry: Add nlohmann-json and gtest to dependencies
Disable building test in yocto env to relaxe Yocto build process.
Tested:
- Builded romulus image with telemetry service
(From meta-phosphor rev: 7406d55ad9690d8820215196279f840c22dce27f)
Change-Id: I12986102d0d7b8fa375ae3e3e4d601304be50d96
Signed-off-by: Wludzik, Jozef <jozef.wludzik@intel.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
index 9b21a65..109a675 100644
--- a/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
+++ b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
@@ -8,7 +8,7 @@
SRC_URI = "git://github.com/openbmc/telemetry"
PV = "1.0+git${SRCPV}"
-SRCREV = "73da69064f48aa99d1e4e9a6d9fff4701ed3dea9"
+SRCREV = "a4bf740ce50ed1d714cc40083c0dd73a81d683ef"
S = "${WORKDIR}/git"
@@ -16,8 +16,12 @@
inherit systemd
DEPENDS = "boost \
+ gtest \
+ nlohmann-json \
phosphor-logging \
sdbusplus \
systemd"
SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Telemetry.service"
+EXTRA_OEMESON = "-Dbuildtest=false"
+