meta-quanta: gbs: Move gbs-bmc-update to virtual provider
This is to avoid conflicts with inplace-gbmc-update that's defualt on
gBMC overrides.
Signed-off-by: Brandon Kim <brandonkim@google.com>
Change-Id: I8ccab5760dd8d4b0b5eb8de5cd270e756d5fa2aa
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
index a177586..da67200 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
@@ -2,11 +2,9 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
inherit systemd
inherit obmc-phosphor-systemd
-
SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
file://bmc-verify.sh \
file://config-bmc.json \
@@ -14,6 +12,9 @@
FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
+PROVIDES += "virtual/bmc-update"
+RPROVIDES_${PN} += "virtual/bmc-update"
+
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-flash"
RDEPENDS_${PN} = "bash"