meta-google: libcr51: suppress openssl warnings

Tested: builds

Signed-off-by: Nan Zhou <nanzhoumails@gmail.com>
Change-Id: I43d7ff60626c11195c887dfb169aec72c171e1f8
diff --git a/meta-google/recipes-google/libcr51sign/libcr51sign_git.bb b/meta-google/recipes-google/libcr51sign/libcr51sign_git.bb
index c4fd78c..618df72 100644
--- a/meta-google/recipes-google/libcr51sign/libcr51sign_git.bb
+++ b/meta-google/recipes-google/libcr51sign/libcr51sign_git.bb
@@ -6,6 +6,11 @@
 
 inherit pkgconfig
 
+# We need to suppress these warnings in OpenSSL 3.0+ until a fix is available
+CFLAGS += " \
+  -Wno-deprecated-declarations \
+"
+
 DEPENDS += " \
   openssl \
 "