openpower: ipl version bump ..d3d5471263
Jayanth Othayoth (15):
libphal: Add exception class support for pdbg utils
libphal: isTgtPresent API support
libphal: isTgtFunctional API support
libphal: isPrimary processor API support
libphal: getPrimaryProc API support
libphal: getCFAM API support
libphal: putCFAM API support
libphal: sbe setState API support
libphal: sbe getState API support
libphal: sbe isPrimaryIplDone API support
libphal: sbe isDumpAllowed API support
libphal: sbe getDump API support
libphal: isSbeVitalAttnActive API support
libphal: update in pdbg init function
libphal: fix validateSBEState function build issue
Added pdata dependencies to enable phal devtree custom api's
Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Change-Id: Ibb4d487989ba0c2c2edd965f5bf88bc8f060e017
diff --git a/meta-openpower/recipes-bsp/ipl/ipl_git.bb b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
index 485b517..4c6f827 100644
--- a/meta-openpower/recipes-bsp/ipl/ipl_git.bb
+++ b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
@@ -7,15 +7,15 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-inherit autotools
+inherit autotools pkgconfig
S = "${WORKDIR}/git"
SRC_URI = "git://git@github.com/open-power/ipl;branch="main""
-SRCREV = "ea1162e71b10e3979fdad64c32f95d1f69362de2"
+SRCREV = "40f24df6dc4172986bbcb5f0d62dac1fc8f2c4c9"
DEPENDS = " \
- libekb pdbg autoconf-archive guard \
+ libekb pdbg autoconf-archive guard pdata \
"
RDEPENDS:${PN} = "phal-devtree"