openpower: pdbg: Bump version to v3.6
gdbserver improvements:
- Power9 and Power10 support
- Multi thread debugging support
- Updates to parser
libpdbg changes:
- Remove attn API, it was unused and is now part of the gdbserver
- Change behaviour of sbe_get_state to suit phal consumer
- Fix thread_stop
- Remove printing from thread_regs functions
Signed-off-by: Joel Stanley <joel@jms.id.au>
Change-Id: I5101cbd6df3c92fc11ea323f8ae6db4d18ddb5cf
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb
new file mode 100644
index 0000000..d0788b9
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb
@@ -0,0 +1,15 @@
+SUMMARY = "PowerPC FSI Debugger"
+DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI += "git://github.com/open-power/pdbg.git;branch=master;protocol=https"
+SRCREV = "3a21a79267bc5faa9e4bc56dc3124be610e9d475"
+
+DEPENDS += "dtc-native"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+BBCLASSEXTEND = "native"