1s4u: support presence config.json for new system
The 1s4u is just like the 2s4u except it has two less fans.
Tested:
- Booted up system with entity-manager loading rainier-1s4u config and
verified fan applications found and loaded new 1s4u files and system
was able to chassis power on.
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I575a63edb242c1b94e1a6f1eafd86a96e4518e37
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index efbdea1..8817592 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -3,6 +3,7 @@
SRC_URI_witherspoon = "file://config.json"
SRC_URI_rainier = "file://rainier-2u/config.json \
file://rainier-4u/config.json \
+ file://rainier-1s4u/config.json \
file://everest/config.json \
"
@@ -14,8 +15,10 @@
# Install Rainier-2U/4U fan presence config files
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+ install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+ install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
# Install Everest fan presence config file
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
@@ -28,4 +31,5 @@
FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
+FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"