Swift: Remove pre-poweron VRM manipulation
Swift doesn't need to run the vrm-control.sh script to set VRM
voltages, which also means it doesn't need to disable/enable their
AVS buses around it, nor bind/unbind the VRM device drivers.
Remove all of these services, and also create a new recipe for
power-workarounds.sh that was in the avsbus-control recipe so that
it can remain.
(From meta-ibm rev: 65ced2221d38ce08dd7dcc46ec254b1bdd4a714f)
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: Ib64cc45499292ae84689fb11400ff9ff0f5f5942
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend
index 4cac490..45deee5 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend
@@ -1,3 +1,4 @@
-RDEPENDS_${PN} += 'avsbus-control'
-RDEPENDS_${PN} += 'vrm-control'
+RDEPENDS_${PN}_witherspoon_append = ' avsbus-control'
+RDEPENDS_${PN}_witherspoon_append = ' vrm-control'
+RDEPENDS_${PN}_append = ' power-workarounds'
RDEPENDS_${PN}_remove += "p9-vcs-workaround"