meta-openembedded: subtree update:ef1b17f4ef..290ad988fb
Alistair Francis (6):
python3-padaos: Initial commit of version 0.1.10
python3-padatious: Initial commit of 0.4.7
python3-petact: Initial commit of version 0.1.2
python3-precise-runner: Initial commit of version 0.3.1
python3-pulsectl: Initial version of 18.12.5
python3-pychromecast: Initial commit of version 4.0.1
Bartosz Golaszewski (1):
python-jsonschema: add python-setuptools-scm to RDEPENDS
Daniel Ammann (1):
dhex: Add new recipe
Khem Raj (5):
dfu-utils: Switch src_uri to sourceforge.net
dfu-util-native: Dont build static binary
live555: Switch SRC_URI where archives are kept for longer
kernel-selftest: Exclude from world builds
uim: Update to 1.8.8
Oleksandr Kravchuk (2):
pcsc-lite: update to 1.8.25
xf86-video-nouveau: update to 1.0.16
Ricardo Salveti (2):
python-pyrsistent: add recipe
python-jsonschema: rdepends on attrs and pyrsistent
S. Lockwood-Childs (1):
wireshark: remove restriction to ARM ISA
Slater, Joseph (1):
live555: update to version 20190828
Vincent Prince (3):
python*-psutil: Add native and nativesdk to BBCLASSEXTEND
python3-cheetah: add recipe
python3-regex: add recipe
Yuan Chao (8):
python-more-itertools: new recipe
python-zipp: new recipe
python-pathlib2: new recipe
python-packaging: new recipe
python-importlib-metadata: new recipe
python-pytest: fix runtime error
libtevent: upgrade 0.10.0 -> 0.10.1
cryptsetup: upgrade 2.2.0 -> 2.2.1
cjhasu (1):
Remove "werkzeug-test" in RDEPENDS
Change-Id: Ideadf7469c094d3f26382af6203403ac5c29c6ee
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
index aeca23b..76faefe 100644
--- a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
+++ b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -4,12 +4,15 @@
DEPENDS = "libusb1-native"
-SRC_URI += "file://0001-Revert-Makefile.am-Drop-static-dfu-util.patch"
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
do_deploy() {
- install -m 0755 src/dfu-util_static ${DEPLOYDIR}/dfu-util-${PV}
+ install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
rm -f ${DEPLOYDIR}/dfu-util
ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
}
+
addtask deploy before do_package after do_install