Enabling the avahi service.
Regsitering the following services with avahi.
obmc-console,ssh,sftp(dropbear),obmc-rest
Fixes openbmc/openbmc#548
Fixes openbmc/openbmc#549
Change-Id: I20c31e9e8dfa6d52575bc3c1f55ac62eef82ec13
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/console/obmc-console.bb b/meta-phosphor/common/recipes-phosphor/console/obmc-console.bb
index 36c7403..f6c1db2 100644
--- a/meta-phosphor/common/recipes-phosphor/console/obmc-console.bb
+++ b/meta-phosphor/common/recipes-phosphor/console/obmc-console.bb
@@ -6,6 +6,7 @@
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit autotools
+inherit obmc-phosphor-discovery-service
TARGET_CFLAGS += "-fpic -O2"
@@ -16,6 +17,8 @@
SRCREV = "44580de4e2170c8ee06dbf401315d3acfcf52b22"
+REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
+
SYSTEMD_SERVICE_${PN} = " \
${PN}.service \
${PN}-ssh.socket \