meta-openembedded: subtree update:17fd382f34..679bb49126
Andreas Müller (9):
gparted: upgrade 0.33.0 -> 1.1.0
gjs: 1.58.6 -> 1.58.7
nautilus: upgrade 3.34.2 -> 3.34.3
xfce4-whiskermenu-plugin: upgrade 2.4.3 -> 2.4.4
xfce4-panel: upgrade 4.14.3 -> 4.14.4
poppler: upgrade 0.86.1 -> 0.88.0
mutter: upgrade 3.34.5 -> 3.34.6
openvpn: upgrade 2.4.8 -> 2.4.9
file-roller: upgrade 3.32.4 -> 3.32.5
Honggyu Kim (1):
uftrace: update commit hash to more robust version
Khem Raj (6):
luajit: Disable on rv32
abseil-cpp: Fix build on riscv32
rsyslog: Enable atomic builtins on rv32
python3-grpcio: Fix build with riscv32
waf: Add cross answers for riscv32
libnma: Fix build on riscv32
Mingli Yu (1):
nss: enable uint128 support on mips64
Peter Kjellerstedt (2):
samba: Remove the dependency on libbsd
paho-mqtt-c: Update to the real 1.3.2, and correct the license
Slater, Joseph (1):
syslog-ng: change shebang to python3
Trevor Gamblin (2):
python3-atomicwrites: add python3-misc to RDEPENDS
python3-pysocks: add python3-logging to RDEPENDS
zhengruoqin (4):
python3-pytoml: Modify ptest output format
python3-pytz: Modify ptest output format
python3-scrypt: Modify ptest output format
python3-serpent: Modify ptest output format
Change-Id: I7f985b3e43196dfe5064a954a12411ab6debdb68
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openembedded/meta-gnome/recipes-extended/gparted/gparted_1.1.0.bb b/meta-openembedded/meta-gnome/recipes-extended/gparted/gparted_1.1.0.bb
new file mode 100644
index 0000000..3aaec3c
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-extended/gparted/gparted_1.1.0.bb
@@ -0,0 +1,39 @@
+SUMMARY = "A partition editor to graphically manage disk partitions "
+HOMEPAGE = "http://gparted.org/index.php"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+inherit features_check autotools pkgconfig python3native gnome-help gtk-icon-cache
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
+ file://0001-Install-polkit-action-unconditionally-executable-pke.patch \
+"
+SRC_URI[md5sum] = "0da45cb522d766dfb4886fb3bdbc2634"
+SRC_URI[sha256sum] = "e2fe7b7afbc07e930491c00a05200c2682cc0576ca8f6da87245a000257f5924"
+
+DEPENDS += " \
+ glib-2.0-native \
+ yelp-tools-native \
+ intltool-native \
+ glib-2.0 \
+ gtkmm3 \
+ parted \
+"
+
+FILES_${PN} += " \
+ ${datadir}/appdata \
+ ${datadir}/icons \
+"
+
+PACKAGES += "${PN}-polkit"
+FILES_${PN}-polkit = "${datadir}/polkit-1"
+
+RDEPENDS_${PN} = " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', '${PN}-polkit', '', d)} \
+ dosfstools \
+ mtools \
+ e2fsprogs \
+"