meta-openembedded: subtree update:17fd382f34..679bb49126
Andreas Müller (9):
gparted: upgrade 0.33.0 -> 1.1.0
gjs: 1.58.6 -> 1.58.7
nautilus: upgrade 3.34.2 -> 3.34.3
xfce4-whiskermenu-plugin: upgrade 2.4.3 -> 2.4.4
xfce4-panel: upgrade 4.14.3 -> 4.14.4
poppler: upgrade 0.86.1 -> 0.88.0
mutter: upgrade 3.34.5 -> 3.34.6
openvpn: upgrade 2.4.8 -> 2.4.9
file-roller: upgrade 3.32.4 -> 3.32.5
Honggyu Kim (1):
uftrace: update commit hash to more robust version
Khem Raj (6):
luajit: Disable on rv32
abseil-cpp: Fix build on riscv32
rsyslog: Enable atomic builtins on rv32
python3-grpcio: Fix build with riscv32
waf: Add cross answers for riscv32
libnma: Fix build on riscv32
Mingli Yu (1):
nss: enable uint128 support on mips64
Peter Kjellerstedt (2):
samba: Remove the dependency on libbsd
paho-mqtt-c: Update to the real 1.3.2, and correct the license
Slater, Joseph (1):
syslog-ng: change shebang to python3
Trevor Gamblin (2):
python3-atomicwrites: add python3-misc to RDEPENDS
python3-pysocks: add python3-logging to RDEPENDS
zhengruoqin (4):
python3-pytoml: Modify ptest output format
python3-pytz: Modify ptest output format
python3-scrypt: Modify ptest output format
python3-serpent: Modify ptest output format
Change-Id: I7f985b3e43196dfe5064a954a12411ab6debdb68
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb b/meta-openembedded/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb
new file mode 100644
index 0000000..29b9fc6
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb
@@ -0,0 +1,96 @@
+SUMMARY = "Window and compositing manager based on Clutter"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = " \
+ xserver-xorg-cvt-native \
+ virtual/libx11 \
+ gtk+3 \
+ gdk-pixbuf \
+ cairo \
+ pango \
+ gsettings-desktop-schemas \
+ json-glib \
+ gnome-desktop3 \
+ gnome-settings-daemon \
+ libxtst \
+ libxkbfile \
+ xinerama \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gsettings gobject-introspection gettext upstream-version-is-even features_check
+
+SRC_URI[archive.md5sum] = "20913c458406e6efa3df005a3ce48c8e"
+SRC_URI[archive.sha256sum] = "23bde87d33b8981358831cec8915bb5ff1eaf9c1de74c90cd1660b1b95883526"
+SRC_URI += "file://0001-EGL-Include-EGL-eglmesaext.h.patch"
+
+# x11 is still manadatory - see meson.build
+REQUIRED_DISTRO_FEATURES = "x11"
+
+# systemd can be replaced by libelogind (not available atow - make systemd
+# mandatory distro feature)
+LOGIND ?= "systemd"
+REQUIRED_DISTRO_FEATURES += "systemd"
+
+# profiler requires sysprof 3.34 which is not willing to build atow
+PACKAGECONFIG ??= " \
+ native-backend \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl glx', '', d)} \
+ sm \
+ startup-notification \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl wayland', 'wayland', '', d)} \
+"
+
+EXTRA_OEMESON += " \
+ -Dxwayland_path=${bindir}/Xwayland \
+"
+
+# combi-config - see meson_options.txt for more details
+PACKAGECONFIG[native-backend] = "-Dnative_backend=true -Dudev=true, -Dnative_backend=false -Dudev=false, libdrm virtual/libgbm libinput ${LOGIND} virtual/egl virtual/libgles2 udev"
+PACKAGECONFIG[opengl] = "-Dopengl=true, -Dopengl=true, virtual/libgl"
+PACKAGECONFIG[glx] = "-Dglx=true, -Dglx=false"
+PACKAGECONFIG[libwacom] = "-Dlibwacom=true, -Dlibwacom=false, libwacom"
+PACKAGECONFIG[remote-desktop] = "-Dremote_desktop=true, -Dremote_desktop=false, pipewire-0.2"
+PACKAGECONFIG[sm] = "-Dsm=true, -Dsm=false, libsm"
+PACKAGECONFIG[profiler] = "-Dprofiler=true,-Dprofiler=false,sysprof"
+PACKAGECONFIG[startup-notification] = "-Dstartup_notification=true, -Dstartup_notification=false, startup-notification, startup-notification"
+PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland wayland-native, xserver-xorg-xwayland"
+PACKAGECONFIG[wayland-eglstream] = "-Dwayland_eglstream=true,-Dwayland_eglstream=false"
+
+# yes they changed from mutter-4 -> mutter-5 recently so be perpared
+MUTTER_API_NAME = "mutter-5"
+
+do_install_append() {
+ # Add gir links in standard paths. That makes dependents life much easier
+ # to find them
+ install -d ${D}${datadir}/gir-1.0
+ for gir_full in `find ${D}${libdir}/${MUTTER_API_NAME} -name '*.gir'`; do
+ gir=`basename "$gir_full"`
+ ln -sr "${D}${libdir}/${MUTTER_API_NAME}/$gir" "${D}${datadir}/gir-1.0/$gir"
+ done
+}
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN} += " \
+ ${datadir}/gnome-control-center \
+ ${libdir}/${MUTTER_API_NAME}/lib*${SOLIBS} \
+ ${libdir}/${MUTTER_API_NAME}/*.typelib \
+ ${libdir}/${MUTTER_API_NAME}/plugins \
+"
+
+FILES_${PN}-tests += " \
+ ${datadir}/installed-tests \
+ ${datadir}/${MUTTER_API_NAME}/tests \
+ ${libexecdir}/installed-tests/${MUTTER_API_NAME} \
+"
+
+FILES_${PN}-dev += " \
+ ${libdir}/${MUTTER_API_NAME}/*.gir \
+ ${libdir}/${MUTTER_API_NAME}/lib*.so \
+"
+
+RDEPENDS_${PN} += "zenity"
+