meta-phosphor: Replace phosphor-rest with bmcweb
This patchset replaces the python based phorphor-rest implementation
with bmcweb, a c++ implementation.
bmcweb has several advantages to phosphor rest, and should be the
default implementation for new BMCs. Some of the advantages include:
1. Authentication and authorization is based on PAM
2. Its written in a compiled language, which gives it more applicability
for low resource systems with lower memory.
3. It replicates all the existing phosphor-rest interfaces.
4. Smaller binary size. The bmcweb binary compresses to 800KB at last
measure.
5. bmcweb implements a compliant redfish interface, which phosphor-rest
does not.
6. bmcweb has a selectable build, so features can be enabled/disabled
per platform as needed.
(From meta-phosphor rev: 7bfe2964d1c263d7104fcaabc42806ad0bcff331)
Change-Id: I4a9b5169c2151de633b5227612f15a9e7a771683
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index 6e23d15..a997b2d 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -37,7 +37,7 @@
SUMMARY_${PN}-extras = "Extra features"
RDEPENDS_${PN}-extras = " \
- phosphor-rest \
+ bmcweb \
phosphor-dbus-monitor \
phosphor-systemd-policy \
dbus-broker \