meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override
syntax, including the SYSTEMD_ variables. Change our systemd.bbclass
to do the same for consistency and perform a tree-wide variable
replacement.
Spot checked by building bletchley and witherspoon and checking
some of the SYSTEMD_LINK directives on installed packages under qemu.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
diff --git a/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb b/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb
index 4c4c884..74bb9a0 100644
--- a/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb
+++ b/meta-ibm/recipes-phosphor/power/witherspoon-power-supply-sync.bb
@@ -13,4 +13,4 @@
SYNC_FMT = "../${SYNC_SERVICE}:${TGTFMT}.wants/${SYNC_SERVICE}"
SYSTEMD_SERVICE:${PN} += "${SYNC_SERVICE}"
-SYSTEMD_LINK_${PN} += "${SYNC_FMT}"
+SYSTEMD_LINK:${PN} += "${SYNC_FMT}"