meta-phosphor: change systemd.bbclass to match upstream override syntax

Upstream bbclasses changed to typically use the `:${PN}` override
syntax, including the SYSTEMD_ variables.  Change our systemd.bbclass
to do the same for consistency and perform a tree-wide variable
replacement.

Spot checked by building bletchley and witherspoon and checking
some of the SYSTEMD_LINK directives on installed packages under qemu.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
diff --git a/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
index 7d90446..e2f1468 100644
--- a/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
+++ b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
@@ -1,4 +1,4 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
 # utilize a 600s default timer config for p10bmc
-SYSTEMD_ENVIRONMENT_FILE_${PN}:append:p10bmc = " obmc/watchdog/poweron"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:p10bmc = " obmc/watchdog/poweron"