software-manager-mmc: Use zstd-bin instead of zstd
With openbmc commit 97771a3:
"meta-openembedded: subtree update:7206f7f5bc..98175fd0cc", the zstd
package was split into libraries and binary:
Sean Nyekjaer (3):
zstd: split bin into separate package
This change added an "inherit lib_package" to the zstd recipe which
creates a separate ${PN}-bin package.
Therefore, need to use zstd-bin to include the binary. No need to keep
zstd since the libraries are not needed for code update to extract the
image files.
Tested: Verified the zstd binary existed in the rootfs and code update
was successful in Rainier.
Change-Id: I379ec2b0d85090df5183e3581bc88384eaf4dbc6
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass b/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass
index f30f0c0..d4eb381 100644
--- a/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass
+++ b/meta-phosphor/classes/phosphor-software-manager-mmc.bbclass
@@ -9,7 +9,7 @@
RDEPENDS_phosphor-software-manager-updater-mmc += " \
gptfdisk \
parted \
- zstd \
+ zstd-bin \
"
SYSTEMD_SERVICE_phosphor-software-manager-updater-mmc += " \