linux-nuvoton: WPCM450 and spi fix
The changes below were merged to mainline in v5.13 and have been
backported to the openbmc dev-5.10 tree.
This change brings Nuvoton up to the latest stable tree v5.10.30 and
includes the following backported patches.
Jonathan Neuschäfer (16):
dt-bindings: serial: 8250: Add nuvoton,wpcm450-uart
serial: 8250_of: Add nuvoton,wpcm450-uart
dt-bindings: interrupt-controller: Add nuvoton, wpcm450-aic
irqchip: Add driver for WPCM450 interrupt controller
dt-bindings: arm: Convert nuvoton,npcm750 binding to YAML
ARM: dts: Add board-specific compatible string to npcm750-evb devicetree
clocksource/drivers/npcm: Add support for WPCM450
dt-bindings: timer: nuvoton,npcm7xx: Add wpcm450-timer
dt-bindings: vendor-prefixes: Add Supermicro
dt-bindings: arm: npcm: Add nuvoton,wpcm450 compatible string
dt-bindings: watchdog: npcm: Add nuvoton,wpcm450-wdt
ARM: npcm: Introduce Nuvoton WPCM450 SoC
watchdog: npcm: Add support for WPCM450
ARM: dts: Add devicetree for Nuvoton WPCM450 BMC chip
ARM: dts: Add devicetree for Supermicro X9SCi-LN4F based on WPCM450
MAINTAINERS: Add entry for Nuvoton WPCM450
William A. Kennington III (1):
spi: Fix use-after-free with devm_spi_alloc_*
Change-Id: I29085374c54e7904852f0eb06206b5bb62104d1b
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb b/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb
index 3a06a3e..efaabff 100644
--- a/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb
+++ b/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb
@@ -1,6 +1,6 @@
KBRANCH ?= "dev-5.10"
-LINUX_VERSION ?= "5.10.23"
+LINUX_VERSION ?= "5.10.30"
-SRCREV="395847787d8f955f03bcb350ed9f852346fcda4d"
+SRCREV="4c64c5ceebe8210bb838e74500077a0e944ca825"
require linux-nuvoton.inc