meta-openembedded: subtree update:713e70bd25..5caca0f7bd
Andreas Müller (1):
fluidsynth: upgrade 2.1.2 -> 2.1.3
Domarys Correa (6):
python3-pytest: Update 5.3.5 -> 5.4.2
python3-pytest-html: Update 1.6 -> 2.1.1
python3-pytest-metadata: Update 1.8.0 -> 1.9.0
python3-pytest-asyncio: Update 0.10.0 -> 0.12.0
python3-pyudev: Update 0.21.0 -> 0.22.0
python3-pyyaml: Update 5.3 -> 5.3.1
Hongxu Jia (1):
multipath-tools: fix compiling parallel issue
Kai Kang (1):
plymouth: disable systemd-integration for sysvinit
Khem Raj (1):
dfu-util-native: Remove DEPLOY_DIR_TOOLS from sstate-outputdirs
Konrad Weihmann (14):
pugixml: fix typo for homepage
distuils-extra: fix typo for DESCRIPTION
brotli: fix typo for DESCRIPTION
wxwidgets: fix typo for DESCRIPTION
passwdqc: remove double modify operation
zbar: fix typo for DESCRIPTION
sound-theme-freedesktop: remove double depends
python3-cmd2: remove double colorama in RDEPENDS
python3-smbus2: remove duplicate RDEPENDS settings
python3-twisted: remove double var modification
spawn-fcgi: fix typo in SUMMARY
physfs: fix typo for HOMEPAGE
rest: fix typo for HOMEPAGE
proftpd: Fix typo for SRC_URI[md5sum]
Leon Anavi (4):
python3-click: Upgrade 7.0 -> 7.1.2
python3-dbussy: Upgrade 1.2.1 -> 1.3
python3-imageio: Upgrade 2.6.0 -> 2.8.0
python3-colorama: Upgrade 0.4.1 -> 0.4.3
Maciej Pijanowski (1):
qpdf: fix typo in RDEPENDS
Martin Jansa (1):
irssi: package libirc_proxy.a in PN-staticdev
Michael Haener (1):
cockpit: 219 -> 220
Patrick Williams (1):
net-snmp: refresh patches
Pierre-Jean Texier (2):
libuv: upgrade 1.36.0 -> 1.38.0
uftp: upgrade 4.10.2 -> 5.0
Robert P. J. Day (1):
use weak assignments for PNBLACKLIST in recipe files
Shlomi Vaknin (1):
add python bitstring package
Zang Ruochen (6):
libgphoto2: upgrade 2.5.24 -> 2.5.25
rsyslog: upgrade 8.2002 -> 8.2004
mosquitto: upgrade 1.6.9 -> 1.6.10
snort: upgrade 2.9.15 -> 2.9.16
wireshark: upgrade 3.2.2 -> 3.2.4
cpuid: upgrade 20200211 -> 20200427
Zheng Ruoqin (5):
nano: upgrade 4.9.2 -> 4.9.3
gsoap: upgrade 2.8.100 -> 2.8.103
logwatch: upgrade 7.5.1 -> 7.5.3
mcelog: upgrade 168 -> 170
libnet-dns-perl: upgrade 1.23 -> 1.24
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I697f91df13d9e8d8cb15620aeccd644cdfe53a43
diff --git a/meta-openembedded/meta-oe/recipes-support/gsoap/gsoap_2.8.103.bb b/meta-openembedded/meta-oe/recipes-support/gsoap/gsoap_2.8.103.bb
new file mode 100644
index 0000000..8543c6f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/gsoap/gsoap_2.8.103.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
+for the development of SOAP Web Services and clients."
+SECTION = "devel"
+LICENSE = "GPL-2.0-with-OpenSSL-exception"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
+ file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \
+ "
+SRC_URI[md5sum] = "3207ece9fc8ceb787091de93838f5952"
+SRC_URI[sha256sum] = "afe2ba08d2fa56adc3c774b6741587203a72140a255346e9947b8d2ee6c7d4b6"
+
+inherit autotools
+
+BBCLASSEXTEND = "native"
+
+S = "${WORKDIR}/${BPN}-2.8"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
+
+DEPENDS = "openssl zlib flex bison bison-native"
+DEPENDS_append_class-target = " gsoap-native"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C gsoap $lib ${D}${libdir}
+ done
+}
+
+do_install_class-native() {
+ oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
+}
+
+FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
+FILES_${PN} += "${datadir}"
+FILES_${PN}-staticdev = "${libdir}"
+FILES_${PN}-dev = "${includedir}"
+RRECOMMENDS_${PN}-dev = "${PN}-staticdev"