meta-phosphor:meson: pkgconfig inherit required

Upstream yocto made a change recently that brought to light a bug in
some of our recipes. If your meson makefiles utilize the dependency()
function then the recipe must also include pkgconfig.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Ie85e2a3bd86010c2ce5d08c75fddc1ba348ff891
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index aacb663..07eb75d 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -17,7 +17,7 @@
 
 S = "${WORKDIR}/git"
 
-inherit meson ptest
+inherit pkgconfig meson ptest
 
 SRC_URI += " \
     file://run-ptest \