Enhance Discovery class infrastructure

The service files contains a 'txt' field, where service-specific
data can be added. Addition of this text record facilitates unique
identification of IBM BMCs in a network.

The idea of this commit is to enhance the bbclass to append a
new text record in the avahi static service files. This text
record is added only for avahi and not slp.

Tested By:

The additional data should be in the form of 'Key=Value', else the
build will be terminated with the corresponding error.

The following possibilities are tested:
1. Key=Value        => True
2. Key=             => False
3. Key=Value|       => True
4. =Value           => False
5. Key=Value=       => False
6. ==               => False

(From meta-phosphor rev: 2d6aedfb652bc0e6c7657dae586349823e3fb26d)

Signed-off-by: asmithakarun <asmithkr@in.ibm.com>
Change-Id: Ie0b8466a10097d7fdbfd0c8849a0c0d7145e3923
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 7316d8e..7d11bff 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -21,7 +21,7 @@
 SRCREV = "c5ce2cbd12e395749c3b4abedf0d81f49b402b70"
 PV = "1.0+git${SRCPV}"
 
-REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
+REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200:"
 OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
 SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
 SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"