linux-openbmc: Move to Linux 5.10
This moves the OpenBMC kernel to a v5.10 base for both Aspeed and
Nuvoton. There are 125 patches in the tree, with 80 of those patches not
yet queued for merging in v5.11.
Notably the PECI patchset has been dropped as the author, Intel, has
elected to develop it out of tree instead of submitting it for mainline
inclusion.
The remaining out of tree patches:
Alexander Amelkin (1):
mtd: spi-nor: fix options for mx66l51235f
Andrew Geissler (1):
ARM: dts: tacoma: Add KCS node for LPC MCTP
Andrew Jeffery (9):
dt-bindings: hwmon: pmbus: Add Maxim MAX31785 documentation
pmbus (max31785): Add support for devicetree configuration
pmbus (core): Use driver callbacks in pmbus_get_fan_rate()
pmbus (core): One-shot retries for failure to set page
pmbus (max31785): Wrap all I2C accessors in one-shot failure handlers
ARM: dts: aspeed: witherspoon: Update max31785 node
misc: Add ASPEED KCS driver for MCTP purposes
ARM: dts: witherspoon: Add KCS node for LPC MCTP
ARM: dts: aspeed: rainier: Don't shout addresses
Brad Bishop (3):
ipmi: aspeed-g6: Add compatible strings
reset: simple: Add AST2600 compatibility string
eeprom: at25: Split reads into chunks and cap write size
Cédric Le Goater (19):
mtd: spi-nor: aspeed: use command mode for reads
mtd: spi-nor: aspeed: add support for SPI dual IO read mode
mtd: spi-nor: aspeed: link controller with the ahb clock
mtd: spi-nor: aspeed: optimize read mode
mtd: spi-nor: aspeed: limit the maximum SPI frequency
mtd: spi-nor: aspeed: introduce a aspeed_smc_default_read() helper
mtd: spi-nor: aspeed: clarify 4BYTE address mode mask
mtd: spi-nor: aspeed: use memcpy_fromio() to capture the optimization buffer
mtd: spi-nor: aspeed: add support for the 4B opcodes
mtd: spi-nor: Add support for w25q512jv
mtd: spi-nor: aspeed: Introduce a field for the AHB physical address
mtd: spi-nor: aspeed: Introduce segment operations
mtd: spi-nor: aspeed: add initial support for ast2600
mtd: spi-nor: aspeed: Check for disabled segments on the AST2600
mtd: spi-nor: aspeed: Introduce training operations per platform
mtd: spi-nor: aspeed: Introduce a HCLK mask for training
mtd: spi-nor: aspeed: check upper freq limit when doing training
mtd: spi-nor: aspeed: add support for AST2600 training
/dev/mem: add a devmem kernel parameter to activate the device
Dan Carpenter (1):
soc: aspeed: xdma: Return -EFAULT if copy_from_user() fails
Eddie James (9):
ARM: dts: rainier: Add KCS node for LPC MCTP
ARM: dts: aspeed: Add witherspoon-128 machine
dt-bindings: fsi: Add P10 OCC device documentation
fsi: occ: Add support for P10
hwmon: (occ) Add new temperature sensor type
dt-bindings: input: Add documentation for IBM Operation Panel
input: misc: Add IBM Operation Panel driver
ARM: dts: aspeed: rainier: Mark FSI SPI controllers as restricted
ARM: dts: aspeed: Add Everest BMC machine
Fran Hsu (2):
ARM: dts: nuvoton: npcm730: Add UDC device
ARM: dts: nuvoton: gsj: Add non-mainline nodes
George Hung (2):
dt-binding: edac: add NPCM ECC documentation
edac: npcm: Add Nuvoton NPCM7xx EDAC driver
George Liu (2):
ARM: dts: aspeed: inspur-fp5280g2: Add GPIO line names
ARM: dts: aspeed: inspur-fp5280g2: Add ipsps1 driver
Jae Hyun Yoo (1):
clk: ast2600: enable BCLK for PCI/PCIe bus always
Joel Stanley (4):
ARM: dts: aspeed: ast2600evb: Add MAC0
drm/aspeed: Add sysfs for output settings
net: ftgmac100: Ensure tx descriptor updates are visible
ARM: configs: aspeed: Update defconfigs
Quan Nguyen (1):
ARM: dts: aspeed: Add device tree for Ampere's Mt. Jade BMC
Ryan Sie (1):
ARM: dts: aspeed: Add Supermicro x11spi BMC machine
Tomer Maimon (21):
dt-binding: bmc: Add NPCM7xx LPC BPC documentation
misc: npcm7xx-lpc-bpc: add NPCM7xx BIOS post code driver
dt-binding: bmc: add npcm7xx pci mailbox document
misc: mbox: add npcm7xx pci mailbox driver
dt-binding: net: document NPCM7xx EMC DT bindings
net: npcm: add NPCM7xx Ethernet MAC controller
ARM: dts: npcm7xx: Add out of tree nodes
ARM: dts: olympus: Add non-mainline nodes
ARM: dts: npcm750: Add fuse regmap support node
ARM: dts: npcm7xx: Link fuse syscon to adc and wdt
clk: npcm7xx: add read only flag to divider clocks
iio: adc: Add calibration support to npcm ADC
watchdog: npcm: Add DT restart priority and reset type support
pinctrl: npcm7xx: Add HGPIO pin support to NPCM7xx pinctrl driver
pinctrl: pinconf: add pin persist configuration
pinctrl: npcm7xx: Add pin persist configuration support
spi: npcm-pspi: Add full duplex support
dt-binding: bmc: add NPCM7XX JTAG master documentation
misc: Add NPCM7xx JTAG master driver
watchdog: npcm: Modify get reset status function
ARM: configs: add defconfig for Nuvoton NPCM7xx BMC
Troy Lee (3):
dt-bindings: edac: aspeed-sdram-edac: Add ast2400/ast2600 support
ARM: dts: aspeed: Add AST2600 edac into common devicetree
edac: Supporting AST2400 and AST2600 edac driver
Change-Id: I455ad0dfa67f7224f07b3999b7e3b50755490653
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index 901195c..ed4a10f 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
-KBRANCH ?= "dev-5.8"
-LINUX_VERSION ?= "5.8.17"
+KBRANCH ?= "dev-5.10"
+LINUX_VERSION ?= "5.10.14"
-SRCREV="599d7f997930829f13e05d332e3e7fccd89d340d"
+SRCREV="56621ca6dcf8c20fc7bc72771df00cd3d59c153b"
require linux-aspeed.inc