meta-ibm:host-watchdog: increase timeout to 10 min

The IBM host firmware team has requested an initial timeout of 10
minutes for the host watchdog. The goal is to bring this down once
bringup is complete.

When inband IPMI was used, there was a mechanism for the host to adjust
this timeout so the BMC firmware would set the initial 30 second timeout
and the host firmware would change it to 10 minutes once they started.
With PLDM there is no way for the host to adjust this timeout so we need
to start with the larger value.

Tested:
- Verified a p10bmc image had the new poweron file installed with 10
  minute timeout.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If94766d5f2d62271c4adf366631f0b31a75ef8d0
diff --git a/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
new file mode 100644
index 0000000..0d9704f
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# utilize a 600s default timer config for p10bmc
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_p10bmc = " obmc/watchdog/poweron"