linux-aspeed: Backport v5.13 patches for dts, lpc, spi

The following changes were merged to mainline in v5.13 and have been
backported to the openbmc dev-5.10 tree.

Most are device tree changes, with one fix to the SPI layer and some
changes to the LPC devices to match the new device tree.

Alpana Kumari (2):
      ARM: dts: aspeed: rainier: Add presence GPIOs
      ARM: dts: aspeed: everest: GPIOs support

Brandon Wyman (1):
      ARM: dts: aspeed: everest: Add power supply i2c devices

Chia-Wei, Wang (5):
      dt-bindings: aspeed-lpc: Remove LPC partitioning
      ARM: dts: Remove LPC BMC and Host partitions
      ipmi: kcs: aspeed: Adapt to new LPC DTS layout
      pinctrl: aspeed-g5: Adapt to new LPC device tree layout
      soc: aspeed: Adapt to new LPC device tree layout

Eddie James (9):
      ARM: dts: aspeed: rainier: Enable fan watchdog
      ARM: dts: aspeed: rainier 4U: Fix fan configuration
      ARM: dts: aspeed: everest: Add FSI CFAMs and re-number engines
      ARM: dts: aspeed: everest: Add RTC
      ARM: dts: aspeed: everest: Enable fan watchdog
      ARM: dts: aspeed: Add Rainier 1S4U machine
      ARM: dts: aspeed: Rainier: Fix PCA9552 on bus 8
      ARM: dts: aspeed: Rainier: Fix humidity sensor bus address
      ARM: dts: aspeed: Rainier: Update to pass 2 hardware

Jim Wright (1):
      ARM: dts: aspeed: everest: Add UCD90320 power sequencer

Joel Stanley (2):
      ARM: dts: aspeed: rainier: Add missing fan nodes
      ARM: dts: aspeed: everest: Add size/address cells

Konstantin Aladyshev (1):
      ARM: dts: aspeed: amd-ethanolx: Enable all used I2C busses

Matthew Barth (2):
      ARM: dts: aspeed: everest: Add max31785 fan controller device
      ARM: dts: aspeed: everest: Add pca9552 fan presence

Paul Fertser (1):
      ARM: dts: aspeed: tiogapass: add hotplug controller

Priyanga Ramasamy (1):
      ARM: dts: aspeed: everest: Add I2C components

William A. Kennington III (1):
      spi: Fix use-after-free with devm_spi_alloc_*

Change-Id: Ia5425c9cea3fe025f84e93f688ecd8ffec75ad01
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index 9df9591..53d7f1f 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
 KBRANCH ?= "dev-5.10"
 LINUX_VERSION ?= "5.10.30"
 
-SRCREV="d538d632fb2046278ff3457994d64d43ee2901c7"
+SRCREV="4c64c5ceebe8210bb838e74500077a0e944ca825"
 
 require linux-aspeed.inc