blob: e3664290e3043ad9ee4353c640bfda37928d92ee [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Perl scripting language"
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "devel"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5LIC_FILES_CHKSUM = "file://Copying;md5=5b122a36d0f6dc55279a0ebc69f3c60b \
6 file://Artistic;md5=71a4d5d9acc18c0952a6df2218bb68da \
7 "
8
9
10SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
Brad Bishop15ae2502019-06-18 21:44:24 -040011 https://github.com/arsv/perl-cross/releases/download/1.3/perl-cross-1.3.tar.gz;name=perl-cross \
Brad Bishopc342db32019-05-15 21:57:59 -040012 file://perl-rdepends.txt \
13 file://0001-configure_tool.sh-do-not-quote-the-argument-to-comma.patch \
14 file://0001-ExtUtils-MakeMaker-add-LDFLAGS-when-linking-binary-m.patch \
15 file://0001-Somehow-this-module-breaks-through-the-perl-wrapper-.patch \
16 file://errno_ver.diff \
17 file://native-perlinc.patch \
18 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
19 file://perl-dynloader.patch \
20 file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040021 file://fix-setgroup.patch \
Brad Bishopc8f47122019-06-24 09:36:18 -040022 file://0001-enc2xs-Add-environment-variable-to-suppress-comments.patch \
23 file://0002-Constant-Fix-up-shebang.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040024 "
25SRC_URI_append_class-native = " \
26 file://perl-configpm-switch.patch \
27"
28
Brad Bishop15ae2502019-06-18 21:44:24 -040029SRC_URI[perl.md5sum] = "9770584cdf9b5631c38097645ce33549"
30SRC_URI[perl.sha256sum] = "851213c754d98ccff042caa40ba7a796b2cee88c5325f121be5cbb61bbf975f2"
31SRC_URI[perl-cross.md5sum] = "4dda3daf9c4fe42b3d6a5dd052852a48"
32SRC_URI[perl-cross.sha256sum] = "49edea1ea2cd6c5c47386ca71beda8d150c748835781354dbe7f75b1df27e703"
Brad Bishopc342db32019-05-15 21:57:59 -040033
34S = "${WORKDIR}/perl-${PV}"
35
36inherit upstream-version-is-even
37
38DEPENDS += "db gdbm zlib virtual/crypt"
39
40PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"
41
Brad Bishopc8f47122019-06-24 09:36:18 -040042# Don't generate comments in enc2xs output files. They are not reproducible
43export ENC2XS_NO_COMMENTS = "1"
44
Brad Bishopc342db32019-05-15 21:57:59 -040045do_unpack_append() {
46 bb.build.exec_func('do_copy_perlcross', d)
47}
48
49do_copy_perlcross() {
Brad Bishop15ae2502019-06-18 21:44:24 -040050 cp -rfp ${WORKDIR}/perl-cross*/* ${S}
Brad Bishopc342db32019-05-15 21:57:59 -040051}
52
53do_configure_class-target() {
54 ./configure --prefix=${prefix} --libdir=${libdir} \
55 --target=${TARGET_SYS} \
56 -Duseshrplib \
57 -Dsoname=libperl.so.5 \
58 -Dvendorprefix=${prefix} \
59 -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux
60
61 #perl.c uses an ARCHLIB_EXP define to generate compile-time code that
62 #adds the archlibexp path to @INC during run-time initialization of a
63 #new perl interpreter.
64
65 #Because we've changed this value in a temporary way to make it
66 #possible to use ExtUtils::Embed in the target build (the temporary
67 #value in config.sh gets re-stripped out during packaging), the
68 #ARCHLIB_EXP value that gets generated still uses the temporary version
69 #instead of the original expected version (i.e. becauses it's in the
70 #generated config.h, it doesn't get stripped out during packaging like
71 #the others in config.sh).
72
73 sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h
74}
75
76do_configure_class-nativesdk() {
77 ./configure --prefix=${prefix} \
78 --target=${TARGET_SYS} \
79 -Duseshrplib \
80 -Dsoname=libperl.so.5 \
81 -Dvendorprefix=${prefix} \
82 -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux
83
84 # See the comment above
85 sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h
86}
87
88do_configure_class-native() {
89 ./configure --prefix=${prefix} \
90 -Dbin=${bindir}/perl-native \
91 -Duseshrplib \
92 -Dsoname=libperl.so.5 \
93 -Dvendorprefix=${prefix} \
94 -Ui_xlocale
95}
96
Brad Bishop15ae2502019-06-18 21:44:24 -040097do_configure_append() {
98 if [ -n "$SOURCE_DATE_EPOCH" ]; then
99 PERL_BUILD_DATE="$(${PYTHON} -c "\
100from datetime import datetime, timezone; \
101print(datetime.fromtimestamp($SOURCE_DATE_EPOCH, timezone.utc).strftime('%a %b %d %H:%M:%S %Y')) \
102 ")"
103 echo "#define PERL_BUILD_DATE \"$PERL_BUILD_DATE\"" >> config.h
104 fi
105}
106
Brad Bishopc342db32019-05-15 21:57:59 -0400107do_compile() {
108 oe_runmake
109}
110
111do_install() {
112 oe_runmake 'DESTDIR=${D}' install
113
114 install -d ${D}${libdir}/perl5
115 install -d ${D}${libdir}/perl5/${PV}/
116 install -d ${D}${libdir}/perl5/${PV}/ExtUtils/
117
118 # Save native config
119 install config.sh ${D}${libdir}/perl5
120 install lib/Config.pm ${D}${libdir}/perl5/${PV}/
121 install lib/ExtUtils/typemap ${D}${libdir}/perl5/${PV}/ExtUtils/
122
123 # Fix up shared library
124 rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
125 ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
126}
127
128do_install_append_class-target() {
129 # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch
130 ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl
131
132}
133
134do_install_append_class-nativesdk() {
135 # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch
136 ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl
137
138 create_wrapper ${D}${bindir}/perl \
139 PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/site_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/vendor_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/${PV}'
140}
141
142do_install_append_class-native () {
143 # Those wrappers mean that perl installed from sstate (which may change
144 # path location) works and that in the nativesdk case, the SDK can be
145 # installed to a different location from the one it was built for.
146 create_wrapper ${D}${bindir}/perl-native/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl5/site_perl/${PV}:${STAGING_LIBDIR}/perl5/vendor_perl/${PV}:${STAGING_LIBDIR}/perl5/${PV}'
147
148 # Use /usr/bin/env nativeperl for the perl script.
149 for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
150 sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
151 done
152}
153
154PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
155
156perl_package_preprocess () {
157 # Fix up installed configuration
158 sed -i -e "s,${D},,g" \
159 -e "s,${DEBUG_PREFIX_MAP},,g" \
160 -e "s,--sysroot=${STAGING_DIR_HOST},,g" \
161 -e "s,-isystem${STAGING_INCDIR} ,,g" \
162 -e "s,${STAGING_LIBDIR},${libdir},g" \
163 -e "s,${STAGING_BINDIR},${bindir},g" \
164 -e "s,${STAGING_INCDIR},${includedir},g" \
165 -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
166 -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
167 -e "s,${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX},${bindir},g" \
168 -e 's:${RECIPE_SYSROOT}::g' \
169 ${PKGD}${bindir}/h2xs \
170 ${PKGD}${bindir}/h2ph \
171 ${PKGD}${bindir}/pod2man \
172 ${PKGD}${bindir}/pod2text \
173 ${PKGD}${bindir}/pod2usage \
174 ${PKGD}${bindir}/podchecker \
175 ${PKGD}${bindir}/podselect \
176 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/config.h \
177 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/perl.h \
178 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/pp.h \
179 ${PKGD}${libdir}/perl5/${PV}/Config.pm \
180 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config.pm \
181 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config.pod \
Brad Bishop15ae2502019-06-18 21:44:24 -0400182 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_git.pl \
Brad Bishopc342db32019-05-15 21:57:59 -0400183 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy.pl \
184 ${PKGD}${libdir}/perl5/${PV}/ExtUtils/Liblist/Kid.pm \
185 ${PKGD}${libdir}/perl5/${PV}/FileCache.pm \
186 ${PKGD}${libdir}/perl5/${PV}/pod/*.pod \
187 ${PKGD}${libdir}/perl5/config.sh
188}
189
190require perl-ptest.inc
191
192FILES_${PN} = "${bindir}/perl ${bindir}/perl.real ${bindir}/perl${PV} ${libdir}/libperl.so* \
193 ${libdir}/perl5/site_perl \
194 ${libdir}/perl5/${PV}/Config.pm \
Brad Bishop15ae2502019-06-18 21:44:24 -0400195 ${libdir}/perl5/${PV}/*/Config_git.pl \
Brad Bishopc342db32019-05-15 21:57:59 -0400196 ${libdir}/perl5/${PV}/*/Config_heavy-target.pl \
197 ${libdir}/perl5/config.sh \
198 ${libdir}/perl5/${PV}/strict.pm \
199 ${libdir}/perl5/${PV}/warnings.pm \
200 ${libdir}/perl5/${PV}/warnings \
201 ${libdir}/perl5/${PV}/vars.pm \
202 ${libdir}/perl5/site_perl \
203 "
204RPROVIDES_${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \
205 perl-module-warnings-register"
206
207FILES_${PN}-staticdev_append = " ${libdir}/perl5/${PV}/*/CORE/libperl.a"
208
209FILES_${PN}-dev_append = " ${libdir}/perl5/${PV}/*/CORE"
210
211FILES_${PN}-doc_append = " ${libdir}/perl5/${PV}/Unicode/Collate/*.txt \
212 ${libdir}/perl5/${PV}/*/.packlist \
213 ${libdir}/perl5/${PV}/ExtUtils/MANIFEST.SKIP \
214 ${libdir}/perl5/${PV}/ExtUtils/xsubpp \
215 ${libdir}/perl5/${PV}/ExtUtils/typemap \
216 ${libdir}/perl5/${PV}/Encode/encode.h \
217 "
218PACKAGES += "${PN}-misc"
219
220FILES_${PN}-misc = "${bindir}/*"
221
222PACKAGES += "${PN}-pod"
223
224FILES_${PN}-pod = "${libdir}/perl5/${PV}/pod \
225 ${libdir}/perl5/${PV}/*.pod \
226 ${libdir}/perl5/${PV}/*/*.pod \
227 ${libdir}/perl5/${PV}/*/*/*.pod \
228 ${libdir}/perl5/${PV}/*/*/*/*.pod \
229 "
230
231PACKAGES += "${PN}-module-cpan ${PN}-module-unicore"
232
233FILES_${PN}-module-cpan += "${libdir}/perl5/${PV}/CPAN \
234 "
235FILES_${PN}-module-unicore += "${libdir}/perl5/${PV}/unicore"
236
237# Create a perl-modules package recommending all the other perl
238# packages (actually the non modules packages and not created too)
239ALLOW_EMPTY_${PN}-modules = "1"
240PACKAGES += "${PN}-modules "
241
242PACKAGESPLITFUNCS_prepend = "split_perl_packages "
243
244python split_perl_packages () {
245 libdir = d.expand('${libdir}/perl5/${PV}')
246 do_split_packages(d, libdir, r'.*/auto/([^.]*)/[^/]*\.(so|ld|ix|al)', '${PN}-module-%s', 'perl module %s', recursive=True, match_path=True, prepend=False)
247 do_split_packages(d, libdir, r'.*linux/([^\/]*)\.pm', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
248 do_split_packages(d, libdir, r'Module/([^\/]*)\.pm', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
249 do_split_packages(d, libdir, r'Module/([^\/]*)/.*', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
250 do_split_packages(d, libdir, r'.*linux/([^\/].*)\.(pm|pl|e2x)', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
251 do_split_packages(d, libdir, r'(^(?!(CPAN\/|CPANPLUS\/|Module\/|unicore\/)[^\/]).*)\.(pm|pl|e2x)', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
252
253 # perl-modules should recommend every perl module, and only the
254 # modules. Don't attempt to use the result of do_split_packages() as some
255 # modules are manually split (eg. perl-module-unicore).
256 packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES').split())
257 d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages))
258
259 # Read the pre-generated dependency file, and use it to set module dependecies
260 for line in open(d.expand("${WORKDIR}") + '/perl-rdepends.txt').readlines():
261 splitline = line.split()
262 module = splitline[0].replace("RDEPENDS_perl", "RDEPENDS_${PN}")
263 depends = splitline[2].strip('"').replace("perl-module", "${PN}-module")
264 d.appendVar(d.expand(module), " " + depends)
265}
266
267PACKAGES_DYNAMIC_class-target += "^perl-module-.*"
268PACKAGES_DYNAMIC_class-nativesdk += "^nativesdk-perl-module-.*"
269
270RDEPENDS_${PN}-misc += "perl perl-modules"
271RDEPENDS_${PN}-pod += "perl"
272
273BBCLASSEXTEND = "native nativesdk"
274
275SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
276
277do_create_rdepends_inc() {
278 cd ${WORKDIR}
279 cat <<'EOPREAMBLE' > ${WORKDIR}/perl-rdepends.inc
280
281# Some additional dependencies that the above doesn't manage to figure out
282RDEPENDS_${PN}-module-file-spec += "${PN}-module-file-spec-unix"
283RDEPENDS_${PN}-module-math-bigint += "${PN}-module-math-bigint-calc"
284RDEPENDS_${PN}-module-thread-queue += "${PN}-module-attributes"
285RDEPENDS_${PN}-module-overload += "${PN}-module-overloading"
286
287# Generated depends list beyond this line
288EOPREAMBLE
289 test -e packages-split.new && rm -rf packages-split.new
290 cp -r packages-split packages-split.new && cd packages-split.new
291 find . -name \*.pm | xargs sed -i '/^=head/,/^=cut/d'
292 egrep -r "^\s*(\<use .*|\<require .*);?" perl-module-* --include="*.pm" | \
293 sed "s/\/.*\.pm: */ += /g;s/[\"\']//g;s/;.*/\"/g;s/+= .*\(require\|use\)\> */+= \"perl-module-/g;s/CPANPLUS::.*/cpanplus/g;s/CPAN::.*/cpan/g;s/::/-/g;s/ [^+\"].*//g;s/_/-/g;s/\.pl\"$/\"/;s/\"\?\$/\"/;s/(//;" | tr [:upper:] [:lower:] | \
294 awk '{if ($3 != "\x22"$1"\x22"){ print $0}}'| \
295 grep -v -e "\-vms\-" -e module-5 -e "^$" -e "\\$" -e your -e tk -e autoperl -e html -e http -e parse-cpan -e perl-ostype -e ndbm-file -e module-mac -e fcgi -e lwp -e dbd -e dbix | \
296 sort -u | \
297 sed 's/^/RDEPENDS_/;s/perl-module-/${PN}-module-/g;s/module-\(module-\)/\1/g;s/\(module-load\)-conditional/\1/g;s/encode-configlocal/&-pm/;' | \
298 egrep -wv '=>|module-a|module-apache.?|module-apr|module-authen-sasl|module-b-asmdata|module-convert-ebcdic|module-devel-size|module-digest-perl-md5|module-dumpvalue|module-extutils-constant-aaargh56hash|module-extutils-xssymset|module-file-bsdglob|module-for|module-it|module-io-socket-inet6|module-io-socket-ssl|module-io-string|module-ipc-system-simple|module-lexical|module-local-lib|metadata|module-modperl-util|module-pluggable-object|module-test-builder-io-scalar|module-test2|module-text-unidecode|module-unicore|module-win32|objects\sload|syscall.ph|systeminfo.ph|%s' | \
299 egrep -wv '=>|module-algorithm-diff|module-carp|module-c<extutils-mm-unix>|module-encode-hanextra|module-extutils-makemaker-version-regex|module-file-spec|module-io-compress-lzma|module-locale-maketext-lexicon|module-log-agent|module-meta-notation|module-net-localcfg|module-net-ping-external|module-b-deparse|module-scalar-util|module-some-module|module-symbol|module-uri|module-win32api-file' >> ${WORKDIR}/perl-rdepends.generated
300 cp ${WORKDIR}/perl-rdepends.generated ${THISDIR}/files/perl-rdepends.txt
301}
302
303# bitbake perl -c create_rdepends_inc
304addtask do_create_rdepends_inc
305
306SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
307
308perl_sysroot_create_wrapper () {
309 mkdir -p ${SYSROOT_DESTDIR}${bindir}
310 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
311 # This MUST live in the normal bindir.
312 cat > ${SYSROOT_DESTDIR}${bindir}/nativeperl << EOF
313#!/bin/sh
314realpath=\`readlink -fn \$0\`
315exec \`dirname \$realpath\`/perl-native/perl "\$@"
316EOF
317 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/nativeperl
318 cat ${SYSROOT_DESTDIR}${bindir}/nativeperl
319}
320