Deepak Kodihalli | 75c32cc | 2017-02-05 10:39:06 -0600 | [diff] [blame] | 1 | SUMMARY = "Parser for OpenPOWER-format FRU VPD" |
| 2 | DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit autotools pkgconfig |
| 6 | inherit openpower-fru-vpd |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-systemd |
| 9 | |
| 10 | require ${PN}.inc |
| 11 | |
| 12 | DEPENDS += " \ |
| 13 | virtual/openpower-fru-vpd-layout \ |
| 14 | virtual/openpower-fru-inventory \ |
| 15 | sdbusplus \ |
| 16 | phosphor-logging \ |
| 17 | python-mako-native \ |
| 18 | python-pyyaml-native \ |
| 19 | autoconf-archive-native \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS_${PN} += " \ |
| 23 | sdbusplus \ |
| 24 | phosphor-logging \ |
| 25 | " |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service" |
| 28 | |
| 29 | S = "${WORKDIR}/git" |
| 30 | |
| 31 | EXTRA_OECONF = "FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml" |
| 32 | |
| 33 | do_install_append() { |
| 34 | SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name} |
| 35 | DEST=${D}${inventory_envdir} |
| 36 | install -d ${DEST} |
| 37 | install ${SRC}/inventory ${DEST} |
| 38 | } |