blob: 801b85db887ad037172dc342d5e4f233b4c02b28 [file] [log] [blame]
Deepak Kodihalli75c32cc2017-02-05 10:39:06 -06001SUMMARY = "Parser for OpenPOWER-format FRU VPD"
2DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
3PR = "r1"
4
5inherit autotools pkgconfig
6inherit openpower-fru-vpd
7inherit pythonnative
8inherit obmc-phosphor-systemd
9
10require ${PN}.inc
11
12DEPENDS += " \
13 virtual/openpower-fru-vpd-layout \
14 virtual/openpower-fru-inventory \
15 sdbusplus \
16 phosphor-logging \
17 python-mako-native \
18 python-pyyaml-native \
19 autoconf-archive-native \
20 "
21
22RDEPENDS_${PN} += " \
23 sdbusplus \
24 phosphor-logging \
25 "
26
27SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
28
29S = "${WORKDIR}/git"
30
31EXTRA_OECONF = "FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml"
32
33do_install_append() {
34 SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
35 DEST=${D}${inventory_envdir}
36 install -d ${DEST}
37 install ${SRC}/inventory ${DEST}
38}