Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Wireless Central Regulatory Domain Agent" |
| 2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" |
| 3 | SECTION = "net" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 4 | LICENSE = "copyleft-next-0.3.0" |
| 5 | LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "python-m2crypto-native python-typing-native python-native libnl \ |
| 8 | ${@oe.utils.conditional("DEFAULT_CRYPT", "gcrypt", "libgcrypt", "", d)} \ |
| 9 | ${@oe.utils.conditional("DEFAULT_CRYPT", "openssl", "openssl10", "", d)} \ |
| 10 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 12 | SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ |
| 14 | file://fix-linking-of-libraries-used-by-reglib.patch \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 15 | file://fix-gcc-6-unused-variables.patch \ |
| 16 | file://0001-Makefile-respect-LDFLAGS-for-libreg.patch \ |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 17 | file://make.patch \ |
| 18 | file://use-target-word-size-instead-of-host-s.patch \ |
| 19 | file://fix-issues-when-USE_OPENSSL-1.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 21 | SRC_URI[md5sum] = "0431fef3067bf503dfb464069f06163a" |
| 22 | SRC_URI[sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | inherit python-dir pythonnative siteinfo |
| 25 | |
| 26 | # "gcrypt" or "openssl" |
| 27 | DEFAULT_CRYPT ??= "gcrypt" |
| 28 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | # Recursive make problem |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D} LIBDIR=${libdir}/crda LDLIBREG='-Wl,-rpath,${libdir}/crda -lreg' \ |
| 31 | UDEV_RULE_DIR=${nonarch_libdir}/udev/rules.d/" |
| 32 | EXTRA_OEMAKE_append = " ${@oe.utils.conditional("DEFAULT_CRYPT", "openssl", "USE_OPENSSL=1", "", d)}" |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 33 | TARGET_BITS = "${SITEINFO_BITS}" |
| 34 | export TARGET_BITS |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 35 | |
| 36 | do_compile() { |
| 37 | oe_runmake all_noverify |
| 38 | } |
| 39 | |
| 40 | do_install() { |
| 41 | oe_runmake SBINDIR=${sbindir}/ install |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 42 | } |
| 43 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 44 | RDEPENDS_${PN} = "udev wireless-regdb" |