Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "A CPU benchmark utility" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 2 | DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \ |
| 3 | designed to expose the capabilities of a system's CPU, FPU, \ |
| 4 | and memory system." |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | HOMEPAGE = "http://www.tux.org/~mayer/linux/" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | LICENSE = "nbench-byte" |
| 7 | LIC_FILES_CHKSUM = "file://README;beginline=57;endline=66;md5=020ef579f8fa5746b7e307a54707834f" |
| 8 | SECTION = "console/utils" |
| 9 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | SRC_URI = "https://fossies.org/linux/misc/${BP}.tar.gz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://nbench_32bits.patch \ |
| 12 | file://Makefile-add-more-dependencies-to-pointer.h.patch" |
| 13 | |
| 14 | SRC_URI[md5sum] = "285dfab361080759d477ea1fe7d3093a" |
| 15 | SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac" |
| 16 | |
| 17 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 18 | |
| 19 | TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}" |
| 20 | do_compile() { |
| 21 | oe_runmake |
| 22 | } |
| 23 | |
| 24 | do_install () { |
| 25 | install -d ${D}${bindir} |
| 26 | install -m 0644 NNET.DAT ${D}${bindir}/ |
| 27 | install -m 0755 nbench ${D}${bindir}/ |
| 28 | } |