Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Intel RSTe with Linux OS SSI API Library" |
| 2 | |
| 3 | DESCRIPTION = "Intel Rapid Storage Technology enterprise with Linux OS* Standard Storage Interface API Library. \ |
| 4 | The library allows user to manage storage devices including creating and managing Raid arrays on systems with Intel chipset." |
| 5 | |
| 6 | HOMEPAGE = "http://irstessi.sourceforge.net/" |
| 7 | |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=9d701a2fbb56039fd64afb2262008ddb" |
| 10 | |
| 11 | DEPENDS += "sg3-utils" |
| 12 | |
| 13 | SRC_URI = "http://sourceforge.net/projects/irstessi/files/${BPN}.${PV}.tgz \ |
| 14 | file://0001-log-Avoid-shadowing-functions-from-std-lib.patch \ |
| 15 | file://0002-boost-Backport-clang-support.patch \ |
| 16 | file://0003-engine-Define-discover-const-String-path-in-base-cla.patch \ |
| 17 | file://0004-Do-not-override-flags-coming-from-build-environment.patch \ |
| 18 | file://0005-enable-out-of-source-tree-builds.patch \ |
| 19 | file://0001-Don-t-use-__GNUC_PREREQ.patch \ |
| 20 | file://0002-Use-stangard-int-types.patch \ |
| 21 | file://0003-replace-canonicalize_file_name-with-realpath.patch \ |
| 22 | file://0004-include-limits.h.patch \ |
| 23 | file://0001-Include-libgen.h.patch \ |
| 24 | " |
| 25 | SRC_URI[md5sum] = "d06c9b426437a7697d77266e9835b520" |
| 26 | SRC_URI[sha256sum] = "59daab29363d6e9f07c524029c4239653cfbbee6b0e57fd75df62499728dad8a" |
| 27 | |
| 28 | S ="${WORKDIR}/${BPN}.${PV}" |
| 29 | |
| 30 | inherit autotools |
| 31 | |
| 32 | do_configure_prepend(){ |
| 33 | ${S}/autogen.sh |
| 34 | } |
| 35 | |
| 36 | RDEPENDS_${PN} += "mdadm" |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 37 | |
| 38 | COMPATIBLE_HOST_powerpc = 'null' |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 39 | COMPATIBLE_HOST_powerpc64le = 'null' |