Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Easy API to create and parse X.509 and CMS related objects" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A library to make the tasks of working with X.509 certificates, \ |
| 3 | CMS data and related objects more easy. It provides a highlevel interface to \ |
| 4 | the implemented protocols and presents the data in a consistent way. The \ |
| 5 | library does not rely on another cryptographic library but provides \ |
| 6 | hooks for easy integration with Libgcrypt. " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | HOMEPAGE = "http://www.gnupg.org/related_software/libksba/" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 8 | LICENSE = "GPLv3+ & (GPLv2+ | LGPLv3+)" |
| 9 | LICENSE_${PN} = "GPLv2+ | LGPLv3+" |
| 10 | LICENSE_${PN}-doc = "GPLv3+" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=fd541d83f75d038c4e0617b672ed8bda \ |
| 12 | file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 13 | file://COPYING.GPLv3;md5=2f31b266d3440dd7ee50f92cf67d8e6c \ |
| 14 | file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
| 15 | " |
| 16 | |
| 17 | DEPENDS = "libgpg-error" |
| 18 | |
| 19 | BINCONFIG = "${bindir}/ksba-config" |
| 20 | |
| 21 | inherit autotools binconfig-disabled pkgconfig texinfo |
| 22 | |
| 23 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 24 | SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 25 | file://ksba-add-pkgconfig-support.patch" |
| 26 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 27 | SRC_URI[sha256sum] = "dad683e6f2d915d880aa4bed5cea9a115690b8935b78a1bbe01669189307a48b" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | |
| 29 | do_configure_prepend () { |
| 30 | # Else these could be used in preference to those in aclocal-copy |
| 31 | rm -f ${S}/m4/gpg-error.m4 |
| 32 | } |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 33 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 34 | BBCLASSEXTEND = "native nativesdk" |