Brad Bishop | 65b40a8 | 2016-06-09 22:22:46 -0400 | [diff] [blame] | 1 | # In general this class should only be used by board layers |
| 2 | # that keep their machine-readable-workbook in the skeleton repository. |
| 3 | |
| 4 | inherit allarch |
| 5 | inherit setuptools |
| 6 | |
| 7 | SRC_URI += "git://github.com/openbmc/skeleton;subpath=configs" |
| 8 | S = "${WORKDIR}/configs" |
| 9 | |
| 10 | python() { |
| 11 | machine = d.getVar('MACHINE', True).capitalize() + '.py' |
| 12 | d.setVar('_config_in_skeleton', machine) |
| 13 | } |
| 14 | |
| 15 | do_make_setup() { |
| 16 | cp ${S}/${_config_in_skeleton} \ |
| 17 | ${S}/obmc_system_config.py |
| 18 | cat <<EOF > ${S}/setup.py |
| 19 | from distutils.core import setup |
| 20 | |
| 21 | setup(name='${BPN}', |
| 22 | version='${PR}', |
| 23 | py_modules=['obmc_system_config'], |
| 24 | ) |
| 25 | EOF |
| 26 | } |
| 27 | |
| 28 | addtask make_setup after do_patch before do_configure |