Brad Bishop | 4c3712f | 2019-04-24 19:44:31 -0400 | [diff] [blame] | 1 | inherit systemd |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 2 | inherit useradd |
3 | |||||
4 | USERADD_PACKAGES = "${PN}" | ||||
5 | |||||
6 | # add a user called httpd for the server to assume | ||||
7 | USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb" | ||||
Richard Marian Thomaiyar | 8ac94ce | 2018-08-20 20:14:16 +0530 | [diff] [blame] | 8 | GROUPADD_PARAM_${PN} = "web; redfish" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 9 | |
10 | LICENSE = "Apache-2.0" | ||||
11 | LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b" | ||||
12 | |||||
Ed Tanous | 6e3195d | 2018-03-20 08:42:54 -0700 | [diff] [blame] | 13 | SRC_URI = "git://github.com/openbmc/bmcweb.git" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 14 | |
15 | PV = "1.0+git${SRCPV}" | ||||
Andrew Geissler | d948686 | 2021-02-23 21:50:51 +0000 | [diff] [blame] | 16 | SRCREV = "feaf15005555a3099c7f22a7e3d16c99ccb40e72" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 17 | |
18 | S = "${WORKDIR}/git" | ||||
19 | |||||
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame^] | 20 | DEPENDS = " \ |
21 | openssl \ | ||||
22 | zlib \ | ||||
23 | boost \ | ||||
24 | boost-url \ | ||||
25 | libpam \ | ||||
26 | sdbusplus \ | ||||
27 | gtest \ | ||||
28 | nlohmann-json \ | ||||
29 | libtinyxml2 \ | ||||
30 | " | ||||
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 31 | |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame^] | 32 | RDEPENDS_${PN} += " \ |
33 | jsnbd \ | ||||
34 | " | ||||
Adriana Kobylak | 7e0ff54f | 2018-12-13 11:01:05 -0600 | [diff] [blame] | 35 | |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 36 | FILES_${PN} += "${datadir}/** " |
37 | |||||
Manojkiran Eda | f1f2e24 | 2020-09-02 21:48:12 +0530 | [diff] [blame] | 38 | inherit meson |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 39 | |
Manojkiran Eda | f1f2e24 | 2020-09-02 21:48:12 +0530 | [diff] [blame] | 40 | EXTRA_OEMESON = "--buildtype=minsize -Dtests=disabled -Dyocto-deps=enabled" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 41 | |
Ed Tanous | 74a89f9 | 2018-07-17 10:20:09 -0700 | [diff] [blame] | 42 | SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 43 | |
Manojkiran Eda | f1f2e24 | 2020-09-02 21:48:12 +0530 | [diff] [blame] | 44 | FULL_OPTIMIZATION = "-Os " |