Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "user and group account administration library" |
| 2 | DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \ |
| 3 | and group accounts" |
| 4 | HOMEPAGE = "https://fedorahosted.org/libuser/" |
| 5 | BUGTRACKER = "https://fedorahosted.org/libuser/newticket" |
| 6 | |
| 7 | LICENSE = "LGPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 9 | file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \ |
| 10 | file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1" |
| 11 | |
| 12 | SECTION = "base" |
| 13 | |
| 14 | SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "63e5e5c551e99dc5302b40b80bd6d4f2" |
| 18 | SRC_URI[sha256sum] = "a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b" |
| 19 | |
| 20 | DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native python" |
| 21 | |
| 22 | inherit autotools gettext pythonnative python-dir pkgconfig |
| 23 | |
| 24 | EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}" |
| 25 | |
| 26 | PACKAGES += "${PN}-python " |
| 27 | |
| 28 | FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug" |
| 29 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 30 | |